#opnfv-vswitchperf: VSPERF Weekly Call

Meeting started by mtahhan at 15:48:58 UTC (full logs).

Meeting summary

    1. Roll Call (mtahhan, 15:49:05)
    2. Maryam Tahhan (mtahhan, 15:49:10)
    3. Al Morton (acm, 16:01:09)
    4. Mars Toktonaliev (mars_toktonaliev, 16:01:14)
    5. Simona Coppola (Simona, 16:01:24)

  1. Moongen Overview (mtahhan, 16:04:19)
    1. Provides a LUA script on top of DPDK. (mtahhan, 16:06:03)
    2. Bill has added some low level stats to the LUA script (mtahhan, 16:06:22)
    3. Red Hat have integrated Moongen with an internal test framework. but mostly Bill's repo mirrors Moongen @ github (mtahhan, 16:07:09)
    4. a detailed README exists on github (mtahhan, 16:07:28)
    5. Larry Lamers (ljlamers__, 16:07:37)
    6. additional setup information can be found @ (mtahhan, 16:07:56)
    7. https://raw.githubusercontent.com/bmichalo/MoonGen/opnfv/MoonGenSetUp.html (mtahhan, 16:08:08)
    8. https://github.com/bmichalo/MoonGen/tree/opnfv (mtahhan, 16:08:27)
    9. Today Moongen uses DPDK 1.7.1 (mtahhan, 16:09:55)
    10. it would be a "nice to have" to upgrade to DPDK 2.2 but this is up to the Moongen maintainers. (mtahhan, 16:10:48)
    11. Bill can't run Moongen with DPDK 2.1 or DPDK 2.2, but this isn't an issue for us, we should just use Moongen as a standalone traffic generator (mtahhan, 16:11:42)
    12. examples/opnfv-vsperf.lua is a script that Andrew and Bill wrote modelled on other scripts in the example dir and it runs an RFC2544 test (mtahhan, 16:20:48)
    13. the script does a binary search (mtahhan, 16:22:06)
    14. to find the throughput value for the specified traffic loss % (mtahhan, 16:22:50)
    15. Bill added a validation run to the script to ensure that the throughput value found in the binary search is indeed the x% frameloss throughput value (mtahhan, 16:25:34)
    16. if validation fails the script continues to run the binary search till the validation phase passes. (mtahhan, 16:26:11)

  2. dev update (mtahhan, 16:32:45)
    1. planning for next sprint started, please review and add tasks (Simona, 16:37:36)

  3. Spirent update (mtahhan, 16:38:29)
    1. Sridhar should be pushing some patches to vsperf will use the spirent REST API. (mtahhan, 16:39:23)
    2. Sridhar to follow up on Jira access with Aric (Simona, 16:40:23)
    3. Sridhar has a document for adding a new test case. (mtahhan, 16:40:37)
    4. ACTION: Sridhar to migrate the ppt to rst and push to gerrit (mtahhan, 16:41:51)

  4. Xena update (mtahhan, 16:42:29)
    1. Xena code is written - it just needs to be tested (mtahhan, 16:42:45)
    2. Christian is going to test it - working on installing vsperf (mtahhan, 16:43:24)
    3. having some issues with it. (mtahhan, 16:43:37)
    4. new deadline Friday 5th Feb for feedback (Simona, 16:45:41)
    5. https://etherpad.opnfv.org/p/vSwitchPerfNewTestList (mtahhan, 16:49:13)
    6. ACTION: Maryam to post test results report (Simona, 16:53:46)
    7. https://build.opnfv.org/ci/view/vswitchperf/ (mtahhan, 16:59:01)


Meeting ended at 19:43:16 UTC (full logs).

Action items

  1. Sridhar to migrate the ppt to rst and push to gerrit
  2. Maryam to post test results report


People present (lines said)

  1. mtahhan (36)
  2. Simona (15)
  3. collabot (3)
  4. mars_toktonaliev (1)
  5. acm (1)
  6. ljlamers__ (1)


Generated by MeetBot 0.1.4.