#opnfv-vswitchperf: vsperf weekly

Meeting started by mtahhan__ at 15:01:29 UTC (full logs).

Meeting summary

  1. Dev updates (mtahhan__, 15:01:49)
    1. binary support for OVS has now been merged to vsperf (mtahhan__, 15:02:09)
    2. means you can test binary packages with vsperf now (mtahhan__, 15:02:39)
    3. Moongen: outstanding codeset for latency support, there's a bug in moongen with the latency measurement code (mtahhan__, 15:03:17)
    4. more info to follow on the bug next week (mtahhan__, 15:03:28)
    5. running moongen in a virtual machine/container - however Bill needs the latest version of Moongen, Bill's version is a little bit behind (mtahhan__, 15:04:05)
    6. Bill is trying to merge the code and is encountering some issues that still need to be resolved (mtahhan__, 15:04:38)
    7. requiremetns gathering in release D ongoing (mtahhan__, 15:05:13)
    8. 2889 Address learning and caching implementation to start soon (mtahhan__, 15:05:57)
    9. ACTION: Sridhar info sharing next week on QoS testing (mtahhan__, 15:06:33)

  2. - Yardstick presentation (mtahhan__, 15:07:13)
    1. Martin prepared 3 sample testcases stored inside the vsperf repo (mtahhan__, 15:09:04)
    2. each testcaset to be executed by yardstick is to be defined inside the yaml file (mtahhan__, 15:09:27)
    3. you can also specify the custom config file as a parameter to the yaml test case (mtahhan__, 15:10:59)
    4. you can also pass additional configuration files as arguments to be executed before and after the test case (mtahhan__, 15:11:40)
    5. to allow you some more flexibility (mtahhan__, 15:11:58)
    6. runner: defines which parameters for the test case will be modified by yardstcik itself, so one tet case can be run multiple times with those parameters (mtahhan__, 15:13:02)
    7. we have to use the runner syntax to execute each test case individually and report the results per test case (mtahhan__, 15:14:05)
    8. SLA parameter allows you to set a threshold for pass/fail (mtahhan__, 15:14:32)
    9. of a test case (mtahhan__, 15:14:38)
    10. SLAs for vsperf -> you can use any value that's reported as a result to set a threshold for pass/fail (mtahhan__, 15:15:21)
    11. context - defines what VMs to execute on the DUT (mtahhan__, 15:15:54)
    12. next steps (mtahhan__, 15:21:20)
    13. how do we configure the rules on the vswitch with Yardstick (mtahhan__, 15:21:41)
    14. can be done through a setup-script (mtahhan__, 15:21:59)
    15. but this would mean that we would need a script per setup (mtahhan__, 15:22:17)
    16. will also be more difficult with multi node installations... Needs to be figured out (mtahhan__, 15:22:52)
    17. at the moment yardstick runs on the jumphost (mtahhan__, 15:23:16)
    18. will need some ssh functionality integrated into OVS (mtahhan__, 15:23:33)
    19. vsperf @jumphost vs vsperf in a VM (mtahhan__, 15:24:15)
    20. easier to prepare a VM that can be downloaded and used (mtahhan__, 15:24:31)
    21. only limitation is this ssh feature that will be required (mtahhan__, 15:24:44)


Meeting ended at 15:48:13 UTC (full logs).

Action items

  1. Sridhar info sharing next week on QoS testing


People present (lines said)

  1. mtahhan__ (35)
  2. collabot (3)


Generated by MeetBot 0.1.4.