#opnfv-vswitchperf: VSPERF weekly call

Meeting started by mtahhan__ at 14:59:04 UTC (full logs).

Meeting summary

    1. Roll Call (mtahhan__, 14:59:44)
    2. Maryam Tahhan (mtahhan__, 14:59:50)

  1. Agenda (mtahhan__, 15:01:28)
    1. dev update (mtahhan__, 15:01:38)
    2. QoS Readout (mtahhan__, 15:01:46)
    3. Release D (mtahhan__, 15:01:57)
    4. AOB (mtahhan__, 15:02:05)

  2. dev-update (mtahhan__, 15:02:28)
    1. bug fixes worked on as well as cli parameter updates (mtahhan__, 15:05:32)
    2. https://gerrit.opnfv.org/gerrit/#/dashboard/self (mtahhan__, 15:05:39)
    3. don't be afraid to merge +1'd code (mtahhan__, 15:05:52)
    4. Moongen - latency testing is being worked in (mtahhan__, 15:06:06)
    5. Moongen - running in a VM - work ongoing there (mtahhan__, 15:06:20)
    6. as part of this effort - virtio drivers from master moongen branch have been merged with Bill's tree (mtahhan__, 15:07:17)
    7. not published yet (mtahhan__, 15:07:31)
    8. Bill is seeing packets getting dropped on the Receive side of the virtio ports into the VM on both his branch and the master moongen branch (mtahhan__, 15:08:33)
    9. don't know if the moongen maintainers are aware of the latency bug that exists (mtahhan__, 15:10:28)
    10. github issue will be opened against the repo (mtahhan__, 15:10:41)
    11. 2889 address caching and learning tests still under testing (mtahhan__, 15:12:28)
    12. Sridhar looking at Yardstick support from the yardstick. (mtahhan__, 15:12:48)

  3. QoS Testing Readout - Sridhar (mtahhan__, 15:13:40)
    1. ACTION: - Sridhar to send link to "An internet-wide analysis of Traffic policing" paper to the mailing list (mtahhan__, 15:15:02)
    2. ACTION: Sridhar to upload readout to the readouts wiki (mtahhan__, 15:15:32)
    3. Sridhar walking though how to setup QoS for OVS (mtahhan__, 15:15:51)
    4. OVS doesn't implement QoS itself (mtahhan__, 15:16:27)
    5. it uses a subset of Linux Kernel QoS features (mtahhan__, 15:16:48)
    6. Policing works as expected (mtahhan__, 15:17:32)
    7. traffic shaping is a possible test case that we could look at benchmarking (mtahhan__, 15:17:56)
    8. Al points out that if OVS vsctl is using tc to configure the queuing - then the queuing is happening on the Linux Plane not the vswitch plane (mtahhan__, 15:23:16)
    9. then the testing would really be of the Linux Kernel Queue (mtahhan__, 15:24:14)
    10. Al points out that there is a traffic management benchmarking rfc - 7640 that we might be able to leverage (mtahhan__, 15:24:55)
    11. https://tools.ietf.org/html/rfc7640 (marst, 15:27:16)

  4. Release D planning (mtahhan__, 15:27:36)
    1. goals for moongen - latency testing, CI integration (mtahhan__, 15:34:38)
    2. Al suggests that maybe RFC5481 can be implemented with moongen (mtahhan__, 15:35:04)
    3. Q. if there's a limit on samples, how many samples can you get? (mtahhan__, 15:35:23)
    4. 800/900 per second (mtahhan__, 15:35:35)
    5. it may not be enough (mtahhan__, 15:35:47)
    6. adding more options for tuning to vsperf (mtahhan__, 15:36:12)
    7. binding options, profiles, moving to libvirt instead of Qemu, adding testpmd 16-07 as a switch (mtahhan__, 15:36:57)
    8. are some options (mtahhan__, 15:37:09)
    9. vsperf integrated in a more openstack env (mtahhan__, 15:37:38)
    10. Yardstick integration. (mtahhan__, 15:39:15)
    11. IMIX testing is also something that could be implemented for D (mtahhan__, 15:41:50)
    12. 40Gb integration is also an option for D (mtahhan__, 15:44:34)
    13. Netronome would like to contribute back to vsperf the following features: NIC integration for 40Gb and 25 Gb. Moongen support for Netronome NICs, Drop rate tolerance and traffic patterns (mtahhan__, 15:47:49)
    14. Moongen changes are in the master moongen branch (mtahhan__, 15:48:27)
    15. compilation changes to DPDK for the NICs aren't upstreamed to Moongen yet (mtahhan__, 15:48:56)
    16. ACTION: Bill to look Moongen feature planning for D next week (mtahhan__, 15:53:35)
    17. ACTION: Maryam to to the same for yardstick (mtahhan__, 15:55:08)
    18. Christian - vsperf tuning and options (mtahhan__, 15:55:32)
    19. Prevaze - Netronome features (mtahhan__, 15:56:05)
    20. review IMIX stories already in JIRA (mtahhan__, 15:56:42)


Meeting ended at 15:57:36 UTC (full logs).

Action items

  1. - Sridhar to send link to "An internet-wide analysis of Traffic policing" paper to the mailing list
  2. Sridhar to upload readout to the readouts wiki
  3. Bill to look Moongen feature planning for D next week
  4. Maryam to to the same for yardstick


People present (lines said)

  1. mtahhan__ (54)
  2. collabot (3)
  3. marst (1)
  4. jmorgan1 (1)


Generated by MeetBot 0.1.4.