#opnfv-vswitchperf: VSPERF Weekly call

Meeting started by mtahhan_ at 14:57:07 UTC (full logs).

Meeting summary

    1. Maryam Tahhan (mtahhan_, 14:57:13)
    2. Trevor Cooper (trevor_intel, 15:03:00)
    3. https://github.com/atheurer/lua-trafficgen (mtahhan_, 15:03:06)
    4. new github for our (VSPERF's) our RFC 2544 Lua script (mtahhan_, 15:03:16)

  1. IETF draft (mtahhan_, 15:08:00)
    1. more information added to the draft on soak tests (mtahhan_, 15:08:39)
    2. Diff sent around via email (mtahhan_, 15:08:51)
    3. if we can get the draft merged, we can start a last call (mtahhan_, 15:09:12)
    4. in the BMWG (mtahhan_, 15:09:24)

  2. Moongen (mtahhan_, 15:24:29)
    1. VSPERF-400 That is, our piece of MoonGen - that makes it compatible with the latest upstream master branch (https://github.com/emmericp/MoonGen). It is not ready to be integrated with VSPERF just yet as we are still working through some issues. For example, we just made a fix where queues are now passed as a table to the function that launches a task for calibrate and load slave. This was necessary for master branch parity. (mtahhan_, 15:24:59)
    2. in reference to the github repo shared (mtahhan_, 15:25:26)
    3. VSPERF-383: Add Moongen latency stat collection to VSPerf (mtahhan_, 15:25:36)
    4. As mentioned last week, there appears to be an issue with MoonGen failing to collect latency packets around 9 - 10 Mpps. I'm not doing the work, but another member here at Red Hat is making it a priority and has started to work the issue. (mtahhan_, 15:25:48)
    5. VSPERF-204: Update DPDK version packaged with MoonGen (mtahhan_, 15:26:02)
    6. This is basically done and working, but with respect to VSPERF-400 we should probably leave it open until its complete and ready to be integrated into the rest of the VSPERF infrastructure (mtahhan_, 15:26:10)

  3. teststeps: Generic support of step driven tests (mtahhan_, 15:26:36)
    1. https://gerrit.opnfv.org/gerrit/#/c/22981/ (mtahhan_, 15:26:42)
    2. ACTION: Maryam to close off on opens in https://jira.opnfv.org/browse/VSPERF-385 (mtahhan_, 15:27:11)


Meeting ended at 15:27:21 UTC (full logs).

Action items

  1. Maryam to close off on opens in https://jira.opnfv.org/browse/VSPERF-385


People present (lines said)

  1. mtahhan_ (22)
  2. collabot (3)
  3. trevor_intel (1)


Generated by MeetBot 0.1.4.