#opnfv-vswitchperf: OPNFV VSPERF

Meeting started by trevc at 15:56:26 UTC (full logs).

Meeting summary

    1. Trevor Cooper (trevc, 15:56:37)

  1. Moongen (trevc, 16:04:41)
    1. VSPERF-419 - Moongen not detecting TX traffic (test: phy2phy_tput). Bill says thinks the problem here is that the current stable version of MoonGen associated with VSPERF does not have proper X710 rate control. This has been added in a version of MoonGen that will be going into the next release of VSPERF. However, this is currently on a development git repository (branch) (trevc, 16:07:07)
    2. Christo will test the new version on Friday and update Jira accordingly (trevc, 16:07:37)

  2. Updates from martin (trevc, 16:08:14)
    1. VSPERF-375 (--test-params enhancement) – review comments applied and code merged (trevc, 16:08:41)
    2. VSPERF-422 – update of yardstick scenario + documentation + samples – implementation prepared and verified in my testing environment (single node devstack deployment); patches in review: https://gerrit.opnfv.org/gerrit/#/c/24359/ (vsperf repo – TC samples and docs) https://gerrit.opnfv.org/gerrit/#/c/24361/ (yardstick repo – code + unit test updates) (trevc, 16:09:34)
    3. Martin reported progress on Yardstick integration (trevc, 16:11:14)
    4. A few notes: (trevc, 16:11:25)
    5. Update from RH (Christian) ... Jira 406 (adding testpmd as switch for routing traffic to guest not using OVS) ... has been testing and figuring how to integrate ... should be doen in 2-3 weeks. (trevc, 16:16:23)
    6. Christian finished Jira 258 ... RHEL 7.2 rls scripts for Python 3.3 Martin reviewed and +1. If no further review comments Christian will merge the code. (trevc, 16:18:34)
    7. Christo - Xia interface - isues with intergration ... now using new Ixnetwork. Still have to do Jira 417 - integration testing and doc changes (trevc, 16:21:19)
    8. Sridhar - Finished changes and will update Jira 420 and 395 by end of the week (naming and address learning issues) (trevc, 16:23:30)
    9. Open issue for Yardstick folder or update exisitng Yardstick docs - Sridhar (trevc, 16:26:36)
    10. ACTION: trevor setup a Yardstick integration ehterpad to share progress and issues with yardstick team (trevc, 16:27:04)


Meeting ended at 16:29:13 UTC (full logs).

Action items

  1. trevor setup a Yardstick integration ehterpad to share progress and issues with yardstick team


People present (lines said)

  1. trevc (25)
  2. collabot` (3)


Generated by MeetBot 0.1.4.