#opnfv-vswitchperf: OPNFV VSPERF

Meeting started by trevor_intel at 15:07:44 UTC (full logs).

Meeting summary

    1. started to use YS for benchmarking (acm, 15:07:49)
    2. Trevor Cooper (trevor_intel, 15:08:18)
    3. looked at VSPERF - thought about integration with YS (acm, 15:08:27)
    4. Integration currently only at Traffic Gen mode, missing is YS related parts (automation) (acm, 15:10:00)
    5. Jing is interedted in OVS with DPDK, and testpmd (? missed it) (acm, 15:11:08)
    6. Jing also interested in MoonGen as a TG, YS not using latest branch (?) need 2 DPDK ports. (acm, 15:12:25)
    7. In tests of L2 forwarding, MoonGen receiving more packets than sent, problem with negative values (acm, 15:15:02)
    8. need VSPERF to handle negative packet loss values (?) (acm, 15:16:00)
    9. Jing consideres YS integration of Traffic Gen mode complete. (acm, 15:16:49)
    10. trevor_intel Q: did u just moongen? yes, not interested in any others, partners use MoonGen (acm, 15:18:48)
    11. trevor_intel Q: did u just use Throughput? Some latency meas, but numbers are zero? not interested. (acm, 15:19:57)
    12. Bill: MG is not set up to report Latency in VSPERF today, why the numbers of zero (acm, 15:20:35)
    13. need work on VSPERF side, JIRA ticket exists (acm, 15:21:28)
    14. Bill: MG master branch is very dynamic - took a version and designated that as our "stable" version. (acm, 15:22:18)
    15. Bill = BillMichalowski (acm, 15:23:03)
    16. BillMichalowski: did you post the diffs as patch? please send. Just YS code though. (acm, 15:24:42)
    17. trevor_intel Only MoonGen.py code needs to change - BillMichalowski will look at changes and submit a patch if ok (acm, 15:27:00)
    18. ACTION: BillMichalowski here is the patch https://gerrit.opnfv.org/gerrit/#/c/35379/4 (acm, 15:28:25)
    19. not able to publish data, but results on Throughput were stable (acm, 15:30:47)
    20. ...over several runs (acm, 15:31:26)
    21. Jing says thank you, just downloaded and used (for the most part) (acm, 15:32:17)
    22. trevor_intel: +Sridhar we have a page comparing Traffic Gens, Jing would be interested in the results. Would like to have company comparing results. (acm, 15:34:12)
    23. trevor_intel: gave Jing access to our page with restricted (as of now) results https://wiki.opnfv.org/display/vsperf/Traffic+Generator+Testing (acm, 15:34:59)
    24. Jing chatted in GTM: Changes in trafficgen.lua is un-necessary. I chose to change trafficgen.lua because changing moongen.lua to handle "negative frames" seem more involved. (acm, 15:35:41)
    25. Sridhar looking at Trex performance for single flow. same as Prox and MG, OVS slightly better than VPP (acm, 15:37:36)
    26. Sridhar just throughput for now, latency and multiflow next (acm, 15:38:05)
    27. Sridhar VPP and OVS and Cache hits does not seem to differ with ? (acm, 15:39:14)
    28. back2back test result analysis added to TG page by Al https://gerrit.opnfv.org/gerrit/#/c/35379/4 (trevor_intel, 15:40:45)
    29. link is https://wiki.opnfv.org/display/vsperf/Traffic+Generator+Testing#TrafficGeneratorTesting-AppendixB:Back2BackTestingTimeSeries%28fromCI%29 (trevor_intel, 15:41:04)
    30. Al will look at some additional test cases e.g. PVP (trevor_intel, 15:42:53)
    31. Test is important when servers burst out traffic ... max the network device can handle (trevor_intel, 15:43:48)
    32. B2B result became stable a few weeks ago ... only looked at 2017 results (only started in Feb) (trevor_intel, 15:45:46)
    33. Martin mentioned lab NW issues may be relevant (huge delays in test case execution) (trevor_intel, 15:46:41)
    34. need to look at 2016 results for P2P, there was a lab networking issue untill 3 weeks ago, which may explain the 128 byte change to consistent results. (acm, 15:52:55)
    35. Martin talking with KVM for NFV folks - using testpmd threads for processing, something about master core? multiple cores used (acm, 15:55:00)
    36. trevor_intel: need to look at these results. (acm, 15:55:29)
    37. we need to sort-out the sessions at Summit by e-mail - (acm, 16:01:16)
    38. I see where you were going, there isn't a lot of open time for trevor_intel (acm, 16:01:49)


Meeting ended at 16:03:40 UTC (full logs).

Action items

  1. BillMichalowski here is the patch https://gerrit.opnfv.org/gerrit/#/c/35379/4


People present (lines said)

  1. acm (36)
  2. trevor_intel (14)
  3. collabot` (3)


Generated by MeetBot 0.1.4.