#opnfv-vswitchperf: OPNFV VSPERF

Meeting started by trevor_intel at 14:56:48 UTC (full logs).

Meeting summary

    1. Trevor Cooper (trevor_intel, 14:56:55)

  1. Open Stack summit - Mars looking for copresenters (trevor_intel, 15:06:30)
  2. Ars from previous meeting (trevor_intel, 15:06:48)
    1. ACTION: Al to review latency output (histogram table) from TREX provided by Martin Godalmer and provide feedback (trevor_intel, 15:14:27)
    2. Sridhar is adding STC latency histogram to VSPERF output files ... need to harmonize with TREX ... Sridhar will provide proposal next week (trevor_intel, 15:18:14)
    3. note Martin G is on vacation and back 24th July (trevor_intel, 15:18:46)
    4. TREX recent patch is draft and WIP (going through Intel internal review) (trevor_intel, 15:20:25)
    5. trevor_intel need session on what we need to do with JIRA tagging ... will next week (trevor_intel, 15:21:43)
    6. ACTION: acm update the wiki about the draft ... TBD (trevor_intel, 15:24:04)
    7. Update & modify the description of VSPERF tests in Test API ... done (trevor_intel, 15:25:16)
    8. Test case description in Test API ... try to use a generic approach to be able to easily add test cases and additional test case parameters. Mars is working on this. (trevor_intel, 15:29:53)
    9. VPP support is done ... currently no outstanding requests (trevor_intel, 15:32:09)
    10. Sridhar shared proposal for StressNG application (author is Canonical) for noisy neighbor test cases ... stress VMs. Created OSV based VMs (25MB size) ... should we put in VNF catalog with sampleVNF or in VSPERF? Sridhar will document a test case example to discuss on VSPERF mailing list (for noisy neighbor using stress-NG). (trevor_intel, 15:41:10)
    11. Spirent VM also provides stress and has remote control capability (trevor_intel, 15:42:01)
    12. Sridhar proposes PCAP analysis tool in VSPERF (fmad.io keen to use in VSPERF ... Japanese company). Sridhar will demo next week. (trevor_intel, 15:45:41)
    13. Sridhar notes his work on correlation of TG test results and collectd metrics ... time sync issue ... proposal to sync data will share next week. Spirent has NTP support. (trevor_intel, 15:48:25)
    14. Correlation objectives ... is there relationship with (e.g. collectd) metrics and test results e.g. cpu utilization with drop in throughput. (trevor_intel, 15:50:59)
    15. Tuning CI in POD 12 ... Christian working on this and using sandbox ... propose tuning from Red Hat. Christian having VPN issues (on Red Hat side) (trevor_intel, 15:54:43)
    16. Trevor and Martin to get baseline data for PVP scenarios for single and multi-queue, compare with Christian's data to see if its consistent (trevor_intel, 16:00:30)


Meeting ended at 16:01:08 UTC (full logs).

Action items

  1. Al to review latency output (histogram table) from TREX provided by Martin Godalmer and provide feedback
  2. acm update the wiki about the draft ... TBD


People present (lines said)

  1. trevor_intel (21)
  2. collabot` (3)


Generated by MeetBot 0.1.4.