#opnfv-vswitchperf: OPNFV VSPERF

Meeting started by trevor_intel at 14:45:07 UTC (full logs).

Meeting summary

    1. Trevor Cooper (trevor_intel, 14:45:17)
    2. Al Morton (acm, 15:01:42)

  1. 2. Release milestones update (trevor_intel, 15:03:15)
    1. Need to merge TREX integration and new TCs from Martin (trevor_intel, 15:05:25)
    2. patches for Trex integration and Martin's JIRA: VSPERF-518 should be completed by Aug 11 MS5 (acm, 15:06:51)
    3. Any documentation updates? (acm, 15:07:14)

  2. Documentation (trevor_intel, 15:07:21)
    1. Tuning POD work may add some documentation (trevor_intel, 15:07:39)

  3. Ixia license (trevor_intel, 15:08:38)
    1. Mars used Ixia so it works (trevor_intel, 15:09:03)

  4. Ixia integration work (trevor_intel, 15:10:27)
    1. Still waiting for description of the work from Ixia (trevor_intel, 15:10:46)
    2. Test WG has discussed long duration tests, need Pod resources for this, logistics with 5 installers are complex (acm, 15:12:39)
    3. what are test cases we would like to include? Long duration means 2 weeks. (acm, 15:13:12)
    4. Trevor proposed latency test cases ... need to tune up what we collect to make them useful (trevor_intel, 15:14:25)
    5. trevor_intel proposes latency tests for long duration (acm, 15:14:39)
    6. Al suggests an alternative is many short duration tests ... repeated ... makes results duration easier (trevor_intel, 15:17:37)
    7. look at min max ave collected from many short duration latency tests (acm, 15:18:53)
    8. Sridhar ... what aspect of OVS should we focus on? (trevor_intel, 15:18:53)
    9. for example varying number of flows (trevor_intel, 15:19:32)
    10. Trevor proposes going with Al's suggestion to use current latency tests and repeat (trevor_intel, 15:25:25)
    11. follow-up proposal at Test WG meeting this week (acm, 15:25:53)

  5. Test API (trevor_intel, 15:26:02)
    1. need to discuss naming of a few test cases (acm, 15:28:33)
    2. need to fix time display (currently UNIX format) (acm, 15:28:59)
    3. time for each test should be replrted seperately (acm, 15:29:29)
    4. summary, some small problems and still some things to do, Mars will supply links (acm, 15:30:27)
    5. https://wiki.opnfv.org/display/vsperf/VSPerf+testcases+report (marst, 15:30:54)
    6. Mars described this report on the Wiki - this is a list of all test cases VSPERF has (acm, 15:32:37)
    7. does not include ?? This is the list of tests included in the API (results collected and stored through the API??) (acm, 15:35:33)
    8. ACTION: Trevor schedule a separate meeting to discuss including Morgan or Serena (trevor_intel, 15:40:52)

  6. IMIX (trevor_intel, 15:41:42)
    1. JIRA- 521 (acm, 15:41:56)
    2. https://jira.opnfv.org/browse/VSPERF-521 (trevor_intel, 15:43:37)
    3. Martin and Al discuss 520 and 521 with a view to merge and assign tasks (trevor_intel, 15:45:02)
    4. ACTION: Martin K and acm discuss 520 and 521 with a view to merge and assign tasks (acm, 15:46:43)
    5. related to JIRA 523, Noisy Neighbor tests, so integration of Stress VMs is a sub-task of 523 (acm, 15:49:24)
    6. Sridhar's VMs at github.com/opensource-tnbt/stressng-images (acm, 15:51:15)
    7. Sridhar created thiese VMs after discussion with Stress-ng author, Colin King (acm, 15:51:54)
    8. ACTION: Sridhar will put the VM images into OPNFV artifacts (trevor_intel, 15:53:14)
    9. need to store the VMs with our other VMs, like VLOOP, but apparently need special write access, trouble ticket (acm, 15:53:34)
    10. 523 is a proposal for suffix to test case name (trevor_intel, 15:54:07)
    11. ACE Lee has some MoonGen related questions - should mail to the VSPERF list (acm, 15:57:54)
    12. Ace Lee would like to proposes fixes to Moongen ... suggest send suggestions and questions to VSPERF mailing list (trevor_intel, 15:58:03)
    13. SR's 524 - live results from traffic Generators (acm, 15:59:14)
    14. SR's 525 - want to include *collectd* these all support the bigger task of *correlation* (acm, 16:00:33)

  7. CI tuning (trevor_intel, 16:03:34)
    1. has done much to isolate CPUs, want to try this profile on the Sandbox, ... (acm, 16:04:28)
    2. ... but this profile is for Centos, most of Pod uses Ubuntu 16.04 (acm, 16:05:06)
    3. uses tuneadm profile, have a new one for Centos 7.3, if recommend this to the community then we shouldget similar numbers (acm, 16:06:25)
    4. so, documentation needed recommending a consistent baseline configuration and these are the perf numbers you should get... (acm, 16:08:20)


Meeting ended at 16:09:31 UTC (full logs).

Action items

  1. Trevor schedule a separate meeting to discuss including Morgan or Serena
  2. Martin K and acm discuss 520 and 521 with a view to merge and assign tasks
  3. Sridhar will put the VM images into OPNFV artifacts


Action items, by person

  1. acm
    1. Martin K and acm discuss 520 and 521 with a view to merge and assign tasks
  2. UNASSIGNED
    1. Trevor schedule a separate meeting to discuss including Morgan or Serena
    2. Sridhar will put the VM images into OPNFV artifacts


People present (lines said)

  1. acm (34)
  2. trevor_intel (24)
  3. collabot (3)
  4. marst (1)


Generated by MeetBot 0.1.4.