#opnfv-vswitchperf: OPNFV VSPERF

Meeting started by trevor_intel at 14:59:06 UTC (full logs).

Meeting summary

    1. Trevor Cooper (trevor_intel, 15:00:36)
    2. Al Morton (acm, 15:01:22)
    3. MS6 closes this week (acm, 15:03:32)
    4. Martin, e-mail about lab, problem fixed (acm, 15:04:59)
    5. Martin G. has some issue defining Line Rate, now solved due to old version (acm, 15:05:38)
    6. TREX results are very low cf Ixia (trevor_intel, 15:06:02)
    7. Thput numbers are lower than IXIA, may be due to number of cores, only able to reach 5Mil pps for small frames (acm, 15:06:30)
    8. need to consider configurations, similar to Sridhar's performance during T-Gen Tests (acm, 15:07:27)
    9. should result in a patch on Thursday. (acm, 15:08:03)
    10. Al raised topic of T-gen limitations (trevor_intel, 15:08:44)
    11. Seems like TREX does not have limitations for packet and stream creation (trevor_intel, 15:09:07)
    12. Propose looking at generator config files to compare - Sridhar will send out details and config files. Had to use TREX GUI for test setup (manual setup) (trevor_intel, 15:11:22)
    13. ACTION: Sridhar: make configs avaliable, in JIRA (acm, 15:14:15)

  1. Test API (trevor_intel, 15:18:40)
    1. result DB treats all throughput tests (over different packet sizes) as one test, Martin revised start and stop times (acm, 15:20:23)
    2. ACTION: marst please review martin's patch (acm, 15:20:46)
    3. Mars already +1, "beautiful patch" (acm, 15:21:20)
    4. Morgan has asked for completion date, Mars says tested in 12 hours, so probably donetomorrow. (acm, 15:23:33)
    5. min max and average come from T-gen once per second (acm, 15:26:21)
    6. tests are running on Spirent Lab, can run on Intel pod, but with VMs? yes, traffic gen load level and other? issues... (acm, 15:30:13)
    7. trevor_intel how can we actually use any of these results? (acm, 15:30:47)
    8. Sridhar - we can get the same histogram from T-Rex, but need patch. and need patch from IXIA... (acm, 15:32:32)
    9. Sridhar is showing both live collection, and Histogram for results at end of test (acm, 15:33:15)
    10. Spirent VMs on Intel Pod need NTP for delay to work properly (acm, 15:33:55)
    11. Martin - 40% of Sridhar's patch is re-usable for other T-gens. (acm, 15:34:35)
    12. some discussion of collectd and IPFIX to gather Live data during the testing (acm, 15:36:42)
    13. #info for future: run multiple collectors at the same time (as above) (acm, 15:37:37)
    14. Sridhar has a patch to examine collectd simple stats on CPU, OVS, etc. then prepare plots (as acm suggested on e-mail) (acm, 15:39:02)
    15. trevor_intel do we want to commit to this in E-release? there seems to be risk, so do not submit now, it was not announced for E (acm, 15:40:04)
    16. Martin agrees (acm, 15:40:29)
    17. VSPERF-527 is the Story for this. We can close Noisy Neighbor tickets VSPERF 524 and 523 (acm, 15:42:21)
    18. plan is to deprecate artifacts directory (?) (acm, 15:43:26)
    19. Christian not here, but any progress? nothing else tested. (acm, 15:44:52)
    20. SRIOV tests in CI are low, compared to P2P (acm, 15:48:22)
    21. Martin has produced higher results, but not with zero packet loss (acm, 15:48:49)
    22. one VM running with SR-IOV, seems to exceed PCI bus limitations (acm, 15:49:46)
    23. SR-IOV configures two interfaces (virtual?) per one? interface card (acm, 15:52:33)
    24. logical ports on OVS may be limiting factor (acm, 15:53:53)
    25. Martin current SR-IOV may be the limitation of VM with single physical core (acm, 15:54:27)
    26. VSPERF-519 should have documentation related to this and *all* new test cases? (acm, 15:56:53)
    27. we are way behind on documentation for E-release, within the next 3 weeks. (acm, 15:57:46)
    28. minimum we can do is to get the list of test cases that are currently implemented (acm, 15:59:56)
    29. not active now, for future, not for E-release (acm, 16:00:49)


Meeting ended at 16:01:18 UTC (full logs).

Action items

  1. Sridhar: make configs avaliable, in JIRA
  2. marst please review martin's patch


People present (lines said)

  1. acm (46)
  2. trevor_intel (7)
  3. collabot (3)


Generated by MeetBot 0.1.4.