#opnfv-vswitchperf: OPNFV VSPERF

Meeting started by trevor_intel at 14:53:31 UTC (full logs).

Meeting summary

    1. Trevor Cooper (trevor_intel, 14:53:42)

  1. Project description for Euphrates messaging and announcement materials (trevor_intel, 15:05:39)
    1. Al Morton (acm, 15:08:43)
    2. Deadline is friday for reviewing the patch that makes the suggested changes to the Project Description (acm, 15:17:09)

  2. Documentation updates for Euphrates (trevor_intel, 15:19:20)
    1. ACTION: Trevor make doc updates for release (project description, RFC, ...) and clarify with docs team re. latest redthedocs artifacts (trevor_intel, 15:21:14)

  3. Status update related to CI test results (trevor_intel, 15:22:14)
    1. Intel Lab IT "feature" for FW access keeps blocking access. No CI testing till repaired. (acm, 15:23:17)
    2. no CI tests for two weeks. (acm, 15:23:40)
    3. Patch updatign reporting logic could not be tested (trevor_intel, 15:24:12)
    4. Need to check that recent changes have not affected results reporting to DB (acm, 15:24:21)
    5. Tuned profile has not been fully tested with all test cases ... Martin tested one (trevor_intel, 15:25:08)
    6. Christian's recommended changes tested by Martin in PVP scenario, looks stable. (acm, 15:25:08)
    7. Need more tests to confirm stability (acm, 15:26:10)
    8. Christian has doc patch to submit re. tuning configuration ... will submit before Friday (trevor_intel, 15:27:59)
    9. ACTION: Christian will submit patch today/tomorrow (acm, 15:29:56)

  4. Jira SCRUB (trevor_intel, 15:30:14)
    1. Dave McB pushing for this, many tickets related to previous release in other projects. (acm, 15:31:09)
    2. ACTION: all try to update status if closed, move tags out beyond E if not going to be done (acm, 15:32:35)

  5. Multi-flow test configurations (trevor_intel, 15:33:11)
    1. We have explained 4k flow results for 3 different traffic gens (trevor_intel, 15:34:47)
    2. All three generate packets differently (trevor_intel, 15:35:09)
    3. Al has written up results for ETSI NFV TST for purpose of addressing issues in a normative spec (TST009) (trevor_intel, 15:37:15)
    4. Al proposes retest - prox from L3 dst to src and Moongen from L3 src to dst ... Sridhar will rerun tests (trevor_intel, 15:40:36)
    5. Martin will prepare a script to modify Ixia pkt gen too (trevor_intel, 15:41:17)

  6. Representation of VSPERF results on reporting page (trevor_intel, 15:42:04)
    1. Martin provided patch to push results even when they fail (same logic as indicted by Jenkins CI results). Morgan updated explanation on page to be accurate. (trevor_intel, 15:45:46)

  7. DPDK/OVS/VPP/QEMU versions (trevor_intel, 15:46:11)
    1. Haven't been able to verify new versions due to CI being down (trevor_intel, 15:47:26)
    2. Martin suggests updating versions after stable generated and then decide if we should cherry pick to Euphrates (trevor_intel, 15:48:17)

  8. vSwitch metrics (trevor_intel, 15:49:09)
    1. Sridhar using collectd to collect stats for vSwitch daemon and use to create plots (trevor_intel, 15:51:21)
    2. We are collecting metrics on the infrastructure ... very useful for operations (trevor_intel, 15:52:16)
    3. ACTION: Sridhar will demo this next week and show the plots (trevor_intel, 15:53:39)
    4. Sridhar uses Python script to collect metrics and create plots ... will contribute to VSPERF (trevor_intel, 15:54:27)


Meeting ended at 15:55:26 UTC (full logs).

Action items

  1. Trevor make doc updates for release (project description, RFC, ...) and clarify with docs team re. latest redthedocs artifacts
  2. Christian will submit patch today/tomorrow
  3. all try to update status if closed, move tags out beyond E if not going to be done
  4. Sridhar will demo this next week and show the plots


People present (lines said)

  1. trevor_intel (29)
  2. acm (16)
  3. collabot (3)


Generated by MeetBot 0.1.4.