#opnfv-vswitchperf: OPNFV VSPERF

Meeting started by trevor_intel at 15:05:10 UTC (full logs).

Meeting summary

    1. Trevor Cooper (trevor_intel, 15:05:20)

  1. Metrics collection demo (trevor_intel, 15:06:12)
    1. discussion on multi-flow tests (trevor_intel, 15:13:02)
    2. Al Morton (acm, 15:13:02)
    3. Collect d can collect additional parameters that we are not currently collecting (trevor_intel, 15:13:53)
    4. - thanks Sridhar, Trevor, Martin, and Xavier for contribution to the multi-stream investigation this week! (acm, 15:14:22)
    5. Add LLC consumption for core pinned to vSwitch (trevor_intel, 15:14:39)
    6. info discussion on collectd tool which runs on SUT (trevor_intel, 15:18:33)
    7. LTD has test case to monitor CPU and other system metrics while benchmarking takes place ... collectd implements this (trevor_intel, 15:25:43)
    8. there is a test case in the LTD for CPU% and other Infrastructure performance metrics, need to link to this work. (acm, 15:27:52)
    9. Shridar will add LLC profiling test case to VSPERF (trevor_intel, 15:33:58)
    10. https://builders.intel.com/docs/networkbuilders/deterministic_network_functions_virtualization_with_Intel_Resource_Director_Technology.pdf (marst, 15:34:40)
    11. Shridar will share roadmap for noisy neighbor test work in future (trevor_intel, 15:36:11)

  2. Test landing page (trevor_intel, 15:36:49)
    1. http://testresults.opnfv.org/testing/#!/landingpage/table (trevor_intel, 15:37:01)
    2. the objective of adding collectd to expose the Cache Allocation Tech? (CAT) is to observe the capabilities to restrain Noisy Neighbors. (acm, 15:38:40)
    3. If anybody has time please review landing page proposed metrics and information and add you input (trevor_intel, 15:42:25)
    4. Mars will check test descriptions in test catalog are correct (trevor_intel, 15:50:00)

  3. Fuel support for Euphrates (trevor_intel, 15:50:41)
    1. ACTION: Trevor to follow up with Fuel team on VSPERF inclusion as part of Fuel scenario (trevor_intel, 15:53:56)

  4. Intel lab status (trevor_intel, 15:54:29)
    1. No progress ... Trevor will keep VSPERF informed (trevor_intel, 15:55:53)

  5. New TREX bug found by Christian (trevor_intel, 15:57:52)
    1. Multistream is needed to be useful (trevor_intel, 15:58:29)
    2. Martin submitted patch that has been tested by Christian (adds a threshold) ... Christian will merge it. Martin will cherry pick to stable (trevor_intel, 16:01:01)
    3. multistream not implemented (acm, 16:01:39)
    4. TREX multistream feature is still needed (trevor_intel, 16:01:47)


Meeting ended at 16:02:18 UTC (full logs).

Action items

  1. Trevor to follow up with Fuel team on VSPERF inclusion as part of Fuel scenario


People present (lines said)

  1. trevor_intel (23)
  2. acm (5)
  3. collabot (3)
  4. marst (1)


Generated by MeetBot 0.1.4.