#opnfv-vswitchperf: VSPERF

Meeting started by acm at 15:01:08 UTC (full logs).

Meeting summary

    1. Al Morton (acm, 15:04:13)
    2. Al plans to attend the plugfest, Sridhar plans to decide this week (acm, 15:05:13)
    3. no questions on milestones (acm, 15:08:50)

  1. Add multistream support to T-Rex (acm, 15:10:41)
    1. Christian has made a recent update, Martin will look over tomorrow (acm, 15:11:10)
    2. Sridhar has tried the tests, p2p tests seem to show default at 64 streams (acm, 15:11:52)
    3. 03 traffic conf file may need multistream truned off, christian replied (acm, 15:12:57)
    4. L2 Src-only L3 is soruce only, L4 Source only, linear address rotation for now. (acm, 15:14:44)
    5. Sridhar, how to enable Latency measurements? Martin - should be VSperf config, 03_traffic.conf (acm, 15:16:21)
    6. default is 1000 pps (acm, 15:17:38)

  2. Status of tuning CI configuration (Martin) (acm, 15:18:01)
    1. no progress yet, but daily job is running again, results are fluctuating, p2p and pvp results, (acm, 15:19:33)
    2. ACTION: anyone to look into this variation in the results, (acm, 15:20:11)
    3. intel firewall issue has not been resolved, this is a work-around... (acm, 15:21:10)
    4. failures of teh verify jobs are out of our control, seems to be a race condition among shared jobs at those machines. (acm, 15:22:18)
    5. but problem observed since September, re-boot of the shared server fixed for a while. (acm, 15:23:12)
    6. possible work-around is to ask to move our job to another physical server which is not so busy (acm, 15:25:24)
    7. Martin has the admin contacts, was Fatih, now another... (acm, 15:26:49)

  3. (acm, 15:27:56)
  4. Discuss VPP test cases and results in CSIT report (acm, 15:28:04)
    1. https://docs.fd.io/csit/rls1707/report/vpp_performance_tests/overview.html (acm, 15:28:52)
    2. main difference is packet sizes, FDIO CSIT uses IMIX, small and large and Jumbo packet sizes (acm, 15:34:17)
    3. Need some generic API for control, IMIX Genome was proposed. (acm, 15:35:58)
    4. there is a JIRA ticket for this, also for multistream a common definition of fields to manipulate (Wireshark) VSPERF-520 I think (acm, 15:38:20)
    5. Sridhar - will take a look at the specifications, in 2 weeks will summarize study, for IMIX specifications (acm, 15:41:11)
    6. CSIT CPU tuning, not much surprising (acm and Martin), we are using Christian's Tuned recommendation, (acm, 15:45:15)
    7. trade-off betwen tuning complexity and final results. (acm, 15:45:38)
    8. looked at some ETH throughput, seems consistent but with many variables in test codes to understnad further (acm, 15:58:06)
    9. also, at 64 byte frames, the linmitation is the NIC (Niantic) (acm, 15:58:35)
    10. ACTION: the CSIT comparison could prompt new features for F release, everyone to take a look and consider resources needed (acm, 16:00:00)
    11. Sridhar will be on holiday next week (acm, 16:01:44)


Meeting ended at 16:01:55 UTC (full logs).

Action items

  1. anyone to look into this variation in the results,
  2. the CSIT comparison could prompt new features for F release, everyone to take a look and consider resources needed


People present (lines said)

  1. acm (33)
  2. collabot` (3)


Generated by MeetBot 0.1.4.