#opnfv-vswitchperf: vswitchperf weekly meeting

Meeting started by SridharRao at 14:59:27 UTC (full logs).

Meeting summary

  1. Agenda (SridharRao, 14:59:52)
    1. Trevor Cooper (trevor_intel_, 15:02:24)
    2. Al Morton (acm, 15:02:53)
    3. Sridhar has defined 3 options for proportions (trevor_intel_, 15:05:03)
    4. Team to choose which option VSPERF should go ahead. (SridharRao, 15:06:44)
    5. In Table of proportions apart from size and proportion, additional keys should be supported (SridharRao, 15:09:47)
    6. Option B is used by Yardstick (trevor_intel_, 15:20:29)
    7. Disadvantage of Option B is its more verbose (trevor_intel_, 15:20:55)
    8. Option A and B implementation are equivalent (trevor_intel_, 15:21:16)
    9. Preliminary agreement for Option B (trevor_intel_, 15:21:34)

  2. Status of CI Jobs (SridharRao, 15:21:44)
    1. Intel Pod-12 is still down (SridharRao, 15:21:54)
    2. issue: physical servers have been moved, need to investigate ports connections wiring (acm, 15:23:12)
    3. CI forcing execution on alternate Ericsson machine, build 4 machin not utilized as much (acm, 15:24:28)
    4. workload at Ericsson CI could be one possible reason (SridharRao, 15:25:27)
    5. Martin K wet with Maciek from VPP CSIT (Fd.io) (acm, 15:26:38)
    6. confirm how VSPERF has configured cross-connect between VPP ports (acm, 15:27:19)
    7. Macirk says OK (acm, 15:27:39)
    8. Martin to prepare P2P config changes to compare numbers with CSIT tests (trevor_intel_, 15:28:16)
    9. ACM shares information about NFVBench (SridharRao, 15:28:46)
    10. cross-check results with Maciek (acm, 15:29:23)
    11. ACM sees potential in comparision of results from NFVBench and VSPERF (SridharRao, 15:30:43)
    12. Maciek explains that any test with "l2c" is compatable with VSPERF tests (acm, 15:32:08)
    13. scenario they use is 2 server architecture, (acm, 15:32:51)
    14. reason is that traffic gen could not conduct all the encap decap operations at capacity (acm, 15:33:33)
    15. FDIO CSIT matched two VPP implementations to relieve the Traffic Gen from encap decap (acm, 15:34:30)
    16. CSIT uses Trex on UCS (acm, 15:38:08)
    17. CSIT supports PVP or PVVP, but not more Vs (acm, 15:38:43)
    18. VSPERF supports VM chaining with many VMs (acm, 15:39:09)
    19. CSIT limitation can only use 2 VMs (trevor_intel_, 15:39:12)
    20. Martin K will create a JIRA ticket regarding CSIT collaboration future activities (SridharRao, 15:41:43)
    21. Maciek would be interested in comments on new user read-ability of graphs (acm, 15:43:07)
    22. ACTION: acm contact Maciek with feedback (acm, 15:43:28)
    23. trevor mentioned that CSIT results were about half VSPERFs, CSIT uses 1 PMD thread (1:1 with cores) and maps to about same for VSPERF (acm, 15:45:17)
    24. CSIT uses 1, 2 and 4 PMD threads (1 PMD thread = 1 CPU core) (trevor_intel_, 15:45:18)
    25. Martin K explains the challenge in creating 'comparable' environment (CPU, mem) for running tests to compare CSIT results (SridharRao, 15:45:49)
    26. ACTION: Martin to create JIRA ticket (SridharRao, 15:48:19)
    27. https://wiki.opnfv.org/display/SWREL/Summary+of+Release+Plans+for+Fraser (trevor_intel_, 15:49:17)
    28. https://etherpad.opnfv.org/p/vsperf-release-fraser (SridharRao, 15:49:40)
    29. https://etherpad.opnfv.org/p/vsperf-release-fraser (SridharRao, 15:49:59)

  3. Release Plan (SridharRao, 15:58:29)
    1. ACTION: To update the Etherpad with Inputs. (SridharRao, 15:58:57)


Meeting ended at 16:00:48 UTC (full logs).

Action items

  1. acm contact Maciek with feedback
  2. Martin to create JIRA ticket
  3. To update the Etherpad with Inputs.


Action items, by person

  1. acm
    1. acm contact Maciek with feedback
  2. UNASSIGNED
    1. Martin to create JIRA ticket
    2. To update the Etherpad with Inputs.


People present (lines said)

  1. SridharRao (19)
  2. acm (18)
  3. trevor_intel_ (12)
  4. collabot (3)


Generated by MeetBot 0.1.4.