#opnfv-vswitchperf: vswitchperf

Meeting started by SridharRao at 15:58:57 UTC (full logs).

Meeting summary

    1. Long-Duration Tests (SridharRao, 15:59:21)
    2. Results – Histogram. Two Options. Bucket Sizes and %le values. (SridharRao, 15:59:50)

  1. Summary of discussions. (SridharRao, 16:00:16)
    1. earrage (earrage, 16:02:31)

  2. development update. (SridharRao, 16:03:08)
    1. VSPERF-504 is completed. (SridharRao, 16:03:24)
    2. Comparative studies with other projects needs inputs. (SridharRao, 16:05:23)
    3. Al suggests work with Alec for NFVBench. (SridharRao, 16:06:29)
    4. ACTION: Sridhar to focus on NFVBench. (SridharRao, 16:08:52)
    5. ACTION: Mars to focus on CSIT. (SridharRao, 16:09:00)
    6. need volunteers for Yardstick and Bottlenecks. (SridharRao, 16:09:23)
    7. Al Morton (acm, 16:09:26)
    8. Christian is working on the updating the T-Rex Patch - VSPERF-559. (SridharRao, 16:11:08)

  3. architecture design review. (SridharRao, 16:11:30)
    1. Include the TestAPi support flow in the architecture diagram. (SridharRao, 16:14:16)
    2. ACTION: Sridhar to update the architecture diagram. (SridharRao, 16:14:38)
    3. Al Suggested to put the architecture diagram in the Wiki. (SridharRao, 16:15:00)
    4. a key point on teh performance efficiency score: (acm, 16:30:09)
    5. Eddies Idea is to have this normalized (acm, 16:31:00)
    6. a formula that would relate to all resources, clock cycles, memory, resulting in ### packets per second (acm, 16:32:18)

  4. Summary of discussions. (SridharRao, 16:37:07)
    1. din't forget to #endmeeting (acm, 16:38:20)
    2. Long-Duration Tests: RFC2889 Soak tests (LTD spec is updated). Periodical checking. Packet-loss or Frame-rate for deciding when to stop. (SridharRao, 16:38:55)
    3. Results – Histogram.Two options: Bucket sizes and %le values. (SridharRao, 16:39:18)
    4. Traffic Profile: (a)Description of few parameters. (b) IMIX specification - Latency histogram and percentiles. (c) Changing VSPERF conf to YAML is not an option – as it takes significant work. It may apply for TGAAS. (d) definition of frame/packet content needs to be updated – Scapy? (e) These fields - pre_installed_flows', 'flow_type’, 'flow_control', 'learning_frames’ – will continue to remain in VSPERF. It ne (SridharRao, 16:39:29)
    5. TST-009 - Walkthrough and Call for contributions – Inputs from VSPERF. (AL is working on the inputs from the VSPERF). IETF-BMWG inputs to be reviewed (SridharRao, 16:39:39)

  5. Next Round of Discussions. (SridharRao, 16:39:51)
    1. Following Topics were suggested. (SridharRao, 16:40:02)
    2. NFVi forwarding performance and Compliance (verification) program. (SridharRao, 16:40:39)
    3. NFVi forwarding performance and Compliance (verification) program. Performance Efficiency score. (SridharRao, 16:40:55)
    4. Test-Metrics and Infra Structure metrics Correlation. (SridharRao, 16:41:04)
    5. Automation of Deployment and Test-execution. (SridharRao, 16:41:17)
    6. VSPERF and Cloud-native NFV - Containerized NFV. (SridharRao, 16:41:27)


Meeting ended at 16:42:07 UTC (full logs).

Action items

  1. Sridhar to focus on NFVBench.
  2. Mars to focus on CSIT.
  3. Sridhar to update the architecture diagram.


People present (lines said)

  1. SridharRao (33)
  2. acm (5)
  3. collabot` (4)
  4. earrage (1)


Generated by MeetBot 0.1.4.