#opnfv-vswitchperf: OPNFV VSPERF

Meeting started by trevor_intel at 15:57:58 UTC (full logs).

Meeting summary

  1. Rollcall (trevor_intel, 15:58:09)
    1. Trevor Cooper (trevor_intel, 15:58:23)
    2. Al Morton (acn, 15:59:23)

  2. Time Zone change (trevor_intel, 16:04:33)
    1. We will stick with Pacific Time i.e. 8 AM (PST and PDT) (trevor_intel, 16:07:07)
    2. not following UTC (acn, 16:07:31)
    3. ACTION: Sridhar to change meetings to Zoom (trevor_intel, 16:07:56)

  3. Dev update (acn, 16:09:47)
    1. CIs not working (trevor_intel, 16:11:07)
    2. ACTION: Trevor follow up with Martin and help to resolve (trevor_intel, 16:12:02)
    3. See Jira - CI is still not working – details in INFRA-215 and INFRA-220 (trevor_intel, 16:12:45)
    4. ACTION: All please review 3 patches submitted by Martin (trevor_intel, 16:14:21)
    5. Christian has reviewed a patch and is helping Martin resolve T-REX issue (trevor_intel, 16:15:28)
    6. Al has also reviewed one of the patches (trevor_intel, 16:16:01)
    7. Richard Elias has prepared a patch to enhance “--test-params” functionality and to compare (optional) results of several tests in tabular form. Patch will be send for review in next days. (trevor_intel, 16:17:18)
    8. 2. Recap of last week’s discussion - action review (acn, 16:17:44)
    9. Performance Efficiency - Eddie has started to work on a doc to capture ideas and aiming for first draft end of the week (trevor_intel, 16:20:20)
    10. WI = Pc x Cn x Cf where... (acn, 16:20:27)
    11. this will be controversial, but worth pursuing for *some* set of users - maybe this is useful outside of VVP (acn, 16:29:18)

  4. VSPERF results Plotting - Yardstick-Grafana. (Jose, you can share your queries/inputs/requests). (trevor_intel, 16:29:48)
    1. There was a discussion over email (Jose) (trevor_intel, 16:30:13)
    2. 3. VSPERF results Plotting - Yardstick-Grafana. (Jose, you can share your queries/inputs/requests). (acn, 16:30:43)
    3. Waiting for Jose to get back with further questions (trevor_intel, 16:31:18)

  5. VSPERF and Cloud-native NFV (Containerized NFV) (trevor_intel, 16:31:44)
    1. we'll capture coments (acn, 16:32:48)
    2. trevor_intel need to keep evolving/fresh. Containers are NOW. Benchmarking must follow the trends. (acn, 16:34:30)
    3. acm agrees (acn, 16:35:02)
    4. Need assessment of work needed to implement Container-benchmarking (what is re-useable in VSPERF?) (acn, 16:37:46)
    5. We need to understand how VSPERF can be used for container / bare metal performance (trevor_intel, 16:38:07)
    6. K8s is more flexible in resource allocation than hypervisors/VIM (acn, 16:41:49)
    7. istio is a core plugin used in K8s, unit of containers, K8s can replicate containers in a pod, so can scale-up as necessary (microservices) (acn, 16:43:54)
    8. istio connects all the microservice, full mesh communication permitted with "sidecars" (acn, 16:44:55)
    9. flannel and weave handle how traffic moves in/out of cluster (acn, 16:45:26)
    10. K8s doesn't work at L2, all at L3 - web devs don't need to know L2 (acn, 16:46:21)
    11. istio can carve off a portion of traffic to "container #2" ... (acn, 16:47:48)
    12. The emphasis for now is web traffic (stateful) (trevor_intel, 16:49:37)
    13. All based above L3 (trevor_intel, 16:50:20)
    14. forwarding, load balancing, based on L4 - L7 (acn, 16:50:21)
    15. flannel and weave can deal with L3, NAT'd , iptables for static mapping (acn, 16:51:37)
    16. Clover is working on best practices to deliver VNFs in Cloud Native (trevor_intel, 16:53:04)
    17. clover is a set of Best Practices for delivering VNFs in Cloud Native env, using istio, yeager for tracing, prometheus for telemetry data (acn, 16:53:45)
    18. VSPERF would be useful to understand flannel and weave's role (CNI plug-ins) performance to move traffic to K8s (acn, 16:56:47)
    19. K8s uses Docker containers. (acn, 16:58:34)
    20. flannel and weave do the L3 routing, then istio - GRPC is the stateful protocol for communicating between the micro-services. (acn, 17:01:41)
    21. ACTION: Sridhar to present Container Networking next week and continue discussion (trevor_intel, 17:02:36)


Meeting ended at 17:04:06 UTC (full logs).

Action items

  1. Sridhar to change meetings to Zoom
  2. Trevor follow up with Martin and help to resolve
  3. All please review 3 patches submitted by Martin
  4. Sridhar to present Container Networking next week and continue discussion


People present (lines said)

  1. trevor_intel (26)
  2. acn (24)
  3. collabot` (5)
  4. earrage (0)


Generated by MeetBot 0.1.4.