#opnfv-vswitchperf: vswitchperf

Meeting started by SridharRao at 15:02:00 UTC (full logs).

Meeting summary

  1. Development Update (SridharRao, 15:02:14)
    1. Xena-Patch from Christian/Bob multi-flows is merged. (SridharRao, 15:03:10)
    2. Logging Support VSPERF - Should Timestamps be added? (SridharRao, 15:04:01)
    3. Timestamps should be added. (SridharRao, 15:06:38)

  2. Pod-12 Status (SridharRao, 15:07:16)
    1. Al Morton (acm, 15:07:20)
    2. Intel Pods IP (new) We are back online at 192.55.66.214 with the exception of traffic generator. (acm, 15:08:43)
    3. Rerun Tests with Timestamps enabled in logs. (SridharRao, 15:11:42)

  3. VSPERF-Intel Demo IEEE SDN-NFV (SridharRao, 15:13:23)
    1. Create Cache Profiles - L3 Cache. (SridharRao, 15:14:02)
    2. Find a test VNF that is cache-hungry [ Data-plane VNFs - AVB, Video-Servers, TGen-10G-64B] (SridharRao, 15:14:54)
    3. 35-55MB of L3-Cache per socket (SridharRao, 15:17:18)
    4. Experiment Test-VNF and Noisy-Neighbor - without dedicated cacheways (SridharRao, 15:18:51)
    5. Repeat experiment with dedicated cacheways (SridharRao, 15:19:04)
    6. OS Nova cannot balance load across NUMA Nodes (Alec) (acm, 15:23:34)
    7. No OS on Pod 12 (acm, 15:23:56)
    8. Need Pod 19, where there will be a full OS and OPNFV Deployment, then NFV Bench (acm, 15:24:44)
    9. Alec - multiple instances of Testpmd may be sufficient to consume cache (acm, 15:26:00)

  4. Container-Networking - Vswitch-Based Only ? (SridharRao, 15:26:32)
    1. Many options, and K8s adds even more networking options! (acm, 15:27:35)
    2. Sridhar - Should we focus on vSwitch scenarios? (acm, 15:28:32)
    3. Alec - first decision is to use K8s or not (acm, 15:28:51)
    4. SR - Assume no K8s, just Docker Containers, is this worthwhile place to start? (acm, 15:29:45)
    5. vSwitch would be running on baremetal (acm, 15:30:19)
    6. Christian - not plugged-in yet, need to ask RH perf team, get some input (acm, 15:31:05)
    7. (1) Presentation on VSwitch-Based Container Networking. (SridharRao, 15:31:15)
    8. Need info on common use cases today (acm, 15:32:18)
    9. Kubernetes + vSwitches: Solutions/Studies existing (SridharRao, 15:32:35)
    10. Alec - K8s only understands L3, is IP based, no L2 with vSwitch, SR/IOV is working for containers, too. (acm, 15:34:08)
    11. Alec - Intel and VPP/FD.IO have studies on Kubernetes+vSwitch (SridharRao, 15:34:51)
    12. Alec - K8s uses TCP/IP stack in host, and there are some scaling issues when using many containers (acm, 15:35:34)
    13. #info Alec - experiments running TCP/IP stack in user space, with VPP?, with container connectivity at L3 (acm, 15:37:09)
    14. ACTION: Alec627 to send FD.io doc on container networking (acm, 15:40:31)
    15. acm agree with this path, also learn from what others have done when measuring in this space. (acm, 15:44:25)
    16. Alec - L3 today in K8s, but this is not efficient when connecting multiple containers. (acm, 15:51:49)


Meeting ended at 15:58:08 UTC (full logs).

Action items

  1. Alec627 to send FD.io doc on container networking


People present (lines said)

  1. acm (19)
  2. SridharRao (18)
  3. collabot_ (3)
  4. marst (1)


Generated by MeetBot 0.1.4.