#opnfv-vswitchperf: vswitchperf

Meeting started by SRao at 14:59:37 UTC (full logs).

Meeting summary

  1. Development Update (SRao, 15:01:35)
    1. Al Morton (acm, 15:04:26)
    2. We closed the patch on matplotlib - version update. (SRao, 15:05:00)
    3. @Sridhar yet to submit a patch on histogram. (SRao, 15:06:14)

  2. Intern Update (SRao, 15:07:30)
    1. ACTION: acm to help akanksha1702 get access to Intel Pod12 on Pharos - need to create a JIRA ticket. (acm, 15:17:07)
    2. progress on vsperf-container and results-container. (SRao, 15:20:09)
    3. ACTION: akanksha request helpdesk for contributing to vsperf. (SRao, 15:20:55)
    4. ACTION: sridhar share information on how to submit patches to vsperf. (SRao, 15:21:15)
    5. intern updates: https://wiki.opnfv.org/display/vsperf/Intern+Project%3A+VSPERF+Automated+Deployment+and+Results+Management (SRao, 15:22:25)

  3. VLOOP-VNF (SRao, 15:22:46)
    1. Christian: ubuntu image may not be tuned (SRao, 15:24:06)
    2. The image created with fedora - size is huge. (SRao, 15:24:33)
    3. Parameters to consider - VCPUs (default 2, better to assign more), testpmd-queues, cpu-pinning (isolcpus), IRQ-pinning (tuna tool), cpu-affinity (apart from isolcpus), (SRao, 15:32:32)
    4. Christian will follow this up - it may take few weeks. (SRao, 15:34:32)
    5. Run test with 1500bytes, check if any loss at testpmd (guest), if yes, there is some issue with the guest. (SRao, 15:36:26)
    6. Christian to show the approach he take in debugging the guest. (SRao, 15:38:34)

  4. Test-Results (SRao, 15:43:17)
    1. Tests - SRIOV (ubuntu 14.04 VNF): results similar to phy2phy. 5Gb/s. T-Rex. (SRao, 15:44:53)
    2. tested with netEm [TC: 100Mb/s, Egress]. Came across -ve loss and -ve loss %ge. (SRao, 15:46:56)
    3. This behavior (-ve values) around 75 to 90mb/s range. (SRao, 15:47:36)
    4. Trex Stateful tutorial: https://trex-tgn.cisco.com/trex/doc/trex_control_plane_peek.html (SRao, 15:49:41)
    5. ACTION: acm to create wiki on edge-computing characterization, traditional-tools, TGens, TC, etc. (SRao, 15:52:32)

  5. OVS-VANILLA (SRao, 15:57:32)
    1. currently ovs_vanilla is not built. (SRao, 15:58:42)
    2. we have to either (a) change the "default" path for OVS_Vanilla. (b) Build ovs-vanilla also by default (SRao, 15:59:11)
    3. Documentation update is needed. (SRao, 16:00:25)


Meeting ended at 16:00:46 UTC (full logs).

Action items

  1. acm to help akanksha1702 get access to Intel Pod12 on Pharos - need to create a JIRA ticket.
  2. akanksha request helpdesk for contributing to vsperf.
  3. sridhar share information on how to submit patches to vsperf.
  4. acm to create wiki on edge-computing characterization, traditional-tools, TGens, TC, etc.


Action items, by person

  1. acm
    1. acm to help akanksha1702 get access to Intel Pod12 on Pharos - need to create a JIRA ticket.
    2. acm to create wiki on edge-computing characterization, traditional-tools, TGens, TC, etc.
  2. UNASSIGNED
    1. akanksha request helpdesk for contributing to vsperf.
    2. sridhar share information on how to submit patches to vsperf.


People present (lines said)

  1. SRao (27)
  2. collabot (3)
  3. acm (2)


Generated by MeetBot 0.1.4.