#opnfv-vswitchperf: vswitchperf

Meeting started by srao at 15:05:02 UTC (full logs).

Meeting summary

    1. Al Morton (acm, 15:05:16)

  1. development updates (srao, 15:05:17)
    1. Need reviews for 2 "live results" patches. (srao, 15:05:45)
    2. ACTION: Send reminder to Infra JIRA-338 - Access to Bob. (srao, 15:07:05)
    3. Sridhar: Completed a new collector for vsperf - multicmd .. Which will run multiple commands - start and stop external collectors (srao, 15:08:31)
    4. multicmd: collectd, prox, crond, filebeat, plotnetcfg (srao, 15:09:02)
    5. adding support for how the current test-result measures up with "historical" results. (srao, 15:13:20)
    6. CI Status. (srao, 15:15:22)
    7. Node-1 to act as Jenkins Slave. (srao, 15:15:37)
    8. Mars to pick up from where he had stopped and close it soon. (srao, 15:16:39)

  2. VSPERF Results. (srao, 15:17:18)
    1. Should all the logs of the test remain in /tmp or should be moved to results_timestamp/logs/ folder? (srao, 15:18:11)
    2. All agree to move logs to results_timestamp/logs instead of just /tmp : This helps in analysis. (srao, 15:20:26)
    3. ACTION: Sridhar to submit patch for that change. (srao, 15:20:43)
    4. VSPERF and Edge Cloud testing. (srao, 15:21:29)
    5. Option-1: How to correctly concatenate "performance at individual ec-deployment-types" to get the E2E performance? (srao, 15:27:08)
    6. Compute Nodes the topology is Container-Networking + Overlay Networking (srao, 15:28:34)
    7. Container networking - Calico is used, and overlay - OVS-Vxlan (srao, 15:29:01)
    8. Bonding of the Interfaces: Overlay and CN interfaces along with Mgmt & Storage networks. (srao, 15:29:37)
    9. Check: Network Service Mesh Project (srao, 15:32:18)
    10. Nokia's DANM (srao, 15:33:46)
    11. Option-2: Single compute compute Container + VM networking performance. (srao, 15:35:45)
    12. Al: Now that many projects have fixed the "plumbing" challenge.. performance study may become critical (srao, 15:36:22)
    13. Al: "multiflows" helps in higher UDP throughput (srao, 15:39:41)
    14. Tunnel endpoint performance VPP vs OVS - TGens emulating Tunnels can cater this testcase (srao, 15:49:19)
    15. Chances of VSPERF getting intern is high. (srao, 15:50:26)
    16. the "results" part of the annex maybe out - Al has plan-B to present the same in different way. (srao, 15:53:09)
    17. Going ahead - "NUMA" approach may be changed (overcome cross-numa issues) by Chip-Vendors such as Intel. (srao, 15:55:22)

  3. Al experiments: TCP vs UDP for performance tests... We have enough evidence that UDP is better. (srao, 15:58:01)
    1. this information may be know at IETF WGs, but not so common knowledge at other communities (srao, 15:59:31)
    2. Summary; Better go with UDP based Speed and LAtency Test. (srao, 15:59:53)
    3. https://wiki.opnfv.org/pages/viewpage.action?pageId=29098781 (srao, 16:00:49)


Meeting ended at 16:03:26 UTC (full logs).

Action items

  1. Send reminder to Infra JIRA-338 - Access to Bob.
  2. Sridhar to submit patch for that change.


People present (lines said)

  1. srao (33)
  2. acm (3)
  3. collabot (3)


Generated by MeetBot 0.1.4.