#opnfv-vswitchperf: vswitchperf

Meeting started by srao at 14:59:32 UTC (full logs).

Meeting summary

  1. Development Update (srao, 15:00:58)
    1. Team agree to share jupyter notebook with VSPERF distribution. (srao, 15:02:22)
    2. tools/notebooks folder. (srao, 15:02:43)

  2. Intern Introduction. (srao, 15:03:55)
    1. Name: Shailesh. (srao, 15:04:02)
    2. Shailesh will start with Containerization of VSPERF. (srao, 15:04:52)
    3. VSPERF has initial PoC, Shailesh will explore the alternate approach first. (srao, 15:05:18)
    4. Is containerizing VSPERF itself Feasible? Can we install ovs-dpdk and vpp & Spawn VM using qemu commands from the container. (srao, 15:07:08)
    5. ACTION: Create these queries and try to get responses from the community. (srao, 15:07:50)

  3. Version upgrades of upstream software in VSPERF (srao, 15:13:56)
    1. Currently dpdk 17 is used in VSPERF. (srao, 15:14:24)
    2. Trevor: Get latest Version support from OVS and VPP then choose the lowest. (srao, 15:16:52)
    3. Al Morton (acm, 15:17:53)
    4. VPP Ed Warnicke <hagbard@gmail.com> (acm, 15:18:04)
    5. For VNF - vsperf copies the forwarding code and dpdk to vnf and builds it. (srao, 15:22:08)

  4. VSPERF Going Ahead. (srao, 15:24:12)
    1. Bob: It is not clear going ahead what the strategy is. (srao, 15:25:41)
    2. Mars: Investing my spare time, not really official. Some within organization are aware, though. (srao, 15:27:26)
    3. VSPERF's Plan: Containerization, Analytics and Container-Networking. (srao, 15:28:42)
    4. Trevor: Dovetail could be potential target. (srao, 15:31:41)
    5. Trevor: comparison of container-networking technologies. (srao, 15:32:00)
    6. Trevor: VSPERF should highlight the usecase that will be more relevant going ahead. (srao, 15:33:14)
    7. Trevor: Analytics interesting, but may not attract real interest from industry. (srao, 15:36:50)
    8. VSPERF'S Plan: Contribution to Standardization, Container-Networking, Containerization and Analytics. (srao, 15:37:50)
    9. Al: GSMA (NFVI Profile), IETF (BWG), ETSI-NFV (TST). (srao, 15:39:47)
    10. give and take with the NFVI reference platform projects (in general, GSMA, Carrier Task Force, New OPNFV Project, Dovetail) (acm, 15:42:07)
    11. need to understand the new platform performance specifications AND fill any Gaps with VSPERF features (acm, 15:44:04)
    12. New fast path through Kernel AFXDP? Need to agree on interfaces for the acceleration functions - like IPsec (acm, 15:45:35)
    13. AF_Packet and AF_XDP (acm, 15:46:25)
    14. ACTION: new wiki page, directions for VSPERF in next phase, development, coordination, and Standards projects. (acm, 15:50:23)
    15. https://docs.google.com/presentation/d/1nsPINvxQwZZR_7E4mAzr-50eFCBhbCHsmik6DI_yFA0/edit#slide=id.g50f3b155d6_6_626 (trevor_intel, 15:51:57)
    16. Trevor: VSPERF at CNF Testbed? (srao, 15:52:26)
    17. Another work area - Packet loss from Interupts WHite Paper (acm, 15:54:54)
    18. (action for acm) incorporate Binary Search with Loss Verification in VSPERF (try again in Next Release, failed for Hunter) (acm, 15:56:24)
    19. Trevor for container networking comparison : VSPERF should 'generate' results that will add value. (srao, 15:57:31)


Meeting ended at 15:59:58 UTC (full logs).

Action items

  1. Create these queries and try to get responses from the community.
  2. new wiki page, directions for VSPERF in next phase, development, coordination, and Standards projects.


People present (lines said)

  1. srao (27)
  2. acm (9)
  3. collabot (3)
  4. trevor_intel (1)


Generated by MeetBot 0.1.4.