#opnfv-vswitchperf: vswitchperf

Meeting started by srao at 15:03:43 UTC (full logs).

Meeting summary

  1. Development Update. (srao, 15:04:19)
    1. Configuration Generation Patch is merged. (srao, 15:04:36)
    2. Results Container patch is updated with changes suggested. (srao, 15:05:00)
    3. The containers will reside in vswitchperf/tools/docker folder. (srao, 15:06:19)
    4. Under this there will be 3 subfolders. (a) results (b) deploy (c) control/test (srao, 15:07:34)
    5. Sridhar: Focus mostly on Loss Pattern Generation. (srao, 15:07:55)
    6. Pierre: Anca to help vsperf in collecting live results from Ixia TGen. (srao, 15:09:24)
    7. Loss Patterns from different Traffic generators - Ixia, STC, T-Rex. (srao, 15:11:24)
    8. First Complete the T-Rex Live-Results (try lower granularity - in ms, else 1 sec). (srao, 15:13:04)

  2. Containerizing VSPERF. (srao, 15:15:38)
    1. Deploy and Control there will 2 variations: 1. Interactive 2. Automated. (srao, 15:17:12)
    2. Al Morton (acmacm, 15:17:36)
    3. in Interactive the user can do step by step, where as in automated once the container starts it will do everything as per the configuration. (srao, 15:17:54)
    4. the Automated version will help in integrating with Dovetail and X-Testing. (srao, 15:18:32)
    5. in Automated version the user will provide details in the config file - such as testcases to run, the host credentials. (srao, 15:19:12)
    6. Automated Deploy and Interactive Deploy containers are Ready - needs minor fixes and additional sanity checks. (srao, 15:27:47)

  3. Inputs from IETF Meeting (srao, 15:32:30)
    1. Search algorithms in Virtualization world: Multi-level search (0 and 'x'), probabilistic loss ratio with small to large duration. (srao, 15:34:45)
    2. buffer size assessment - back to back testing. (srao, 15:35:12)
    3. TST009 Compliance: First Start with supporting Benchmarks, then Variations in Metrics. (srao, 15:38:38)
    4. ACTION: List the benchmarks and the metrics-variations from TST009. Then Check what all can be supported by which TGen. (srao, 15:41:03)
    5. ACTION: Document the usecase for VSPERF where it can be used for cloud dataplane benchmarking and performance testing. (srao, 15:49:18)
    6. Question: Should we (VSPERF) contribute to chapter-10. All agree that answer is YES. (srao, 15:56:24)


Meeting ended at 16:00:31 UTC (full logs).

Action items

  1. List the benchmarks and the metrics-variations from TST009. Then Check what all can be supported by which TGen.
  2. Document the usecase for VSPERF where it can be used for cloud dataplane benchmarking and performance testing.


People present (lines said)

  1. srao (24)
  2. collabot` (3)
  3. acmacm (1)


Generated by MeetBot 0.1.4.