#opnfv-vswitchperf: vswitchperf

Meeting started by SRao at 15:02:32 UTC (full logs).

Meeting summary

  1. Development Updates (SRao, 15:03:09)
    1. Build Issues - No free hugepages error. (SRao, 15:09:33)
    2. Existing VSPERF - Push results to Testapi based on command line argument only. (SRao, 15:10:03)
    3. Patch: also push based on the configuration parameter. 2-3lines patch. (SRao, 15:10:23)
    4. This helps in automation - containerization. (SRao, 15:10:33)
    5. Py34-> Py36 (SRao, 15:10:58)
    6. Sridhar to submit the patch tomorrow. (SRao, 15:13:08)

  2. VSPERF Upgrades. (SRao, 15:13:30)
    1. DPDK 18.11.2, OVS 2.11.1 and > QEMU 2.10.1 (SRao, 15:14:30)
    2. Emma to represent Intel in VSPERF. (SRao, 15:15:22)
    3. Hari: VSPERF Usage Internally - Regular OVS Testing, Ian Stokes chief maintainer (SRao, 15:18:41)
    4. Hari: Sync Local and Global Repos. (SRao, 15:18:58)
    5. Al Morton (acmacm, 15:21:53)
    6. ACTION: Re-initiate collab with Hari. (SRao, 15:24:00)
    7. Verification of Upgrade: Run All tests. (SRao, 15:25:31)
    8. ACTION: Hari to check with Ian on Testcases and details on IOMMU tests. (SRao, 15:27:17)

  3. CN-Benchmarking (SRao, 15:27:46)
    1. Internship is approved, receiving profiles from students. (SRao, 15:28:31)
    2. ACTION: VIPIN to check with his students. (SRao, 15:28:43)
    3. connected with DanM team - ready to support in 'best-effort' (SRao, 15:29:46)
    4. There is an unconference session at ONS-EU.. Sridhar to attend. (SRao, 15:31:34)
    5. Vipin will also attend ONS-EU. (SRao, 15:32:08)
    6. No response from Multus-Team. (SRao, 15:32:22)
    7. Internship to start Mid/End October (SRao, 15:33:51)
    8. Internship Start date - 1st of October 2019 (SRao, 15:34:20)

  4. Containerization of VSPERF. (SRao, 15:35:05)
    1. Development work is completed.. Sridhar is testing internally. (SRao, 15:35:34)
    2. Submit the patch by end of this week. (SRao, 15:35:44)
    3. Organization: in tools/docker/ 4 folders- client, results, deployment, testcontrol (SRao, 15:36:17)
    4. Single client, 2 version of deployment and testcontrol. (SRao, 15:36:35)
    5. ACTION: Sridhar to start with x-testing integration. (SRao, 15:36:51)
    6. Dovetail integration discussion - yet to start. (SRao, 15:37:43)

  5. Loss-Patterns (SRao, 15:38:24)
    1. Next 3 days Sridhar to re-run all cross-numa tests * 3 and share the liveresults metrics with Vipin - With Spirent TGen. (SRao, 15:39:24)
    2. Anca has started with Ixia. (SRao, 15:39:39)
    3. Vipin trying to fit the distributions of packet loss (acmacm, 15:44:25)
    4. We are trying to understand the causes/sources of the packet loss (acmacm, 15:44:51)
    5. One problem has been to examine packet loss over time, now in SPIRENT (acmacm, 15:46:27)

  6. CNTT-VSPERF. (SRao, 15:47:01)
    1. VSPERF to proactively define and take it to CNTT. (SRao, 15:48:11)
    2. Trevor's Metrics Proposal - To study and evaluate. (SRao, 15:49:56)
    3. https://urldefense.proofpoint.com/v2/url?u=https-3A__wiki.opnfv.org_download_attachments_37684546_CNTT-2520Profile-2520and-2520Metrics-2520discussion-2520-2528OPNFV-252019Aug2019-2529v01.pptx-3Fversion-3D1-26modificationDate-3D1566324310996-26api-3Dv2&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=gComIPka2kS9Ss_-KhCWKUKASEaE6 (acmacm, 15:51:44)
    4. that's trevor's slides (acmacm, 15:52:04)
    5. How much of ETSI TST work CNTT is reusing? (SRao, 15:54:01)
    6. Testcases which can be realized by VSPERF + Functest, VSPERF+Yardstick should be considered. (SRao, 15:56:58)


Meeting ended at 16:00:41 UTC (full logs).

Action items

  1. Re-initiate collab with Hari.
  2. Hari to check with Ian on Testcases and details on IOMMU tests.
  3. VIPIN to check with his students.
  4. Sridhar to start with x-testing integration.


People present (lines said)

  1. SRao (41)
  2. acmacm (7)
  3. collabot` (3)


Generated by MeetBot 0.1.4.