#opnfv-vswitchperf: vswitchperf

Meeting started by SRao at 15:00:31 UTC (full logs).

Meeting summary

  1. Development Update (SRao, 15:00:46)
    1. Sridhar: Submitted patch for VSPERF Containerization. (SRao, 15:02:47)
    2. TODO: Fix Pylint Errors, Fix Documentation. (SRao, 15:03:57)
    3. Use of protobuf. Python files generated through protofuf is also uploaded. We can exclude that. (SRao, 15:04:35)
    4. Shailesh to work fixing the pylint errors. Sridhar to do the remaining. (SRao, 15:06:16)
    5. New Intern. (SRao, 15:07:28)

  2. New Intern (SRao, 15:07:53)
    1. Project: CN benchmarking. Automate the Setup, Deploy and testing. (SRao, 15:08:10)
    2. Alex: Final year, UK. Started from Monday (30th Sept 2019) (SRao, 15:08:44)
    3. Multus/DanM: ovs/vpp/sriov/flannel/calico/cilium/tungsten... (SRao, 15:09:40)
    4. VINAY from NIC. (SRao, 15:12:57)
    5. Vinay Chaudhary: vcteotia@gmail.com (SRao, 15:15:04)
    6. By End of 2019 VSPERF will have CN Benchmarking. User can choose the container and the N/W plugin, VSPERF will perform the rest - Setup, Configure, Deploy, Run test, share results, provide anlytics. (SRao, 15:16:16)
    7. Challenge: (1) Setup of Kubernetes and install of plugins (2) Install OVS and setup TGen (3) Deploy Pod and configure vLinks (4) Run Test and collect results. The challenge is how to insert step 3 between existing steps 2 and 4. Steps 2 and 4 is already what VSPERF is doing. (SRao, 15:19:12)
    8. ACTION: Sridhar to share the alternative next week. (SRao, 15:19:44)
    9. Al Morton (acmacm, 15:20:01)
    10. Alex's first goal is to automate installation of Kubernetes - Master and Worker, and required (configured) plugins (SRao, 15:20:46)

  3. Update on VSPERF Upgrades. (SRao, 15:21:59)
    1. Emma sent update over mail. She will share inputs on testpmd parameters, and they are working some fixes. (SRao, 15:23:02)
    2. Emma: Use OVS 2.11.3 instead of 2.11.2 (SRao, 15:23:19)

  4. VSPERF-Functest (SRao, 15:23:44)
    1. Discussed integration options with Cedric@Functest in ONS-EU 2019. (SRao, 15:24:30)
    2. Use functest container as the base and run tests based on YML configuration - list of Test-name and Command to run that test. (SRao, 15:25:28)
    3. Shailesh has agreed to try this over the weekend. (SRao, 15:25:56)
    4. Deployment will precede this testcontrol. (SRao, 15:28:13)

  5. CNTT-VSPERF (SRao, 15:31:09)
    1. Al: There are lots of requirements for: RM, RA and RI. Take out the key points from them and start prototyping the implementation of these requirements (SRao, 15:33:11)
    2. Al: The tests should be derived from these requirements - these tests should cover as much as the requirements. There may be gaps, which we need to identify. (SRao, 15:34:11)
    3. This page will capture all CNTT-VSPERF activities: https://wiki.opnfv.org/display/vsperf/CNTT+and+VSPERF (SRao, 15:43:27)
    4. Al: Post discussion with Ch 4. the Table 4.4 to be moved to Ch. 8 (SRao, 15:54:24)
    5. AL: Table 4.10 would be moved to Ch. 8 (SRao, 15:56:03)
    6. AL: What may go into Ch. 4 may be from TST 008. (SRao, 15:59:20)


Meeting ended at 16:00:20 UTC (full logs).

Action items

  1. Sridhar to share the alternative next week.


People present (lines said)

  1. SRao (33)
  2. collabot` (3)
  3. acmacm (1)


Generated by MeetBot 0.1.4.