#opnfv-vswitchperf: vswitchperf

Meeting started by SRao at 16:01:17 UTC (full logs).

Meeting summary

    1. Al Morton (acmacm, 16:01:33)

  1. Development Update. (SRao, 16:01:38)
    1. All the patches from Emma et. al., is merged. (SRao, 16:02:33)
    2. Containerization: 20+ stability issues were fixed and updated. (SRao, 16:03:08)
    3. Few more issue to be fixed before sharing it for reviews. (SRao, 16:04:04)
    4. VSPERF Software upgrade - 2 issues. (SRao, 16:04:29)
    5. DPDK: 18.11.2, OVS: 2.12.0 (SRao, 16:05:41)
    6. Error: rte_virtio_pmd_init(): IOPL call failed - cannot use virtio PMD. (SRao, 16:06:39)
    7. ACTION: Sridhar to send the complete log. (SRao, 16:07:00)
    8. New Qemu Version (3.1.1) does not support if=scsi. Error: machine type does not support if=scsi,bus=0,unit=1 (SRao, 16:07:38)
    9. 2 options: Fallback to older version of qemu, or update qemu.py (cmd) (SRao, 16:08:02)
    10. new version of vpp expects python36-devel (this is not available at centos/rhel 7). Commenting the dependency and running, works.. (SRao, 16:09:31)
    11. VPP version 19.04 (SRao, 16:10:01)
    12. Ready with patch for Intel DPPD-PROX in VLOOP-VNF. Will connect with SampleVNF for review. (SRao, 16:12:59)
    13. Using L2FWD Mode. (SRao, 16:14:14)

  2. CN-Benchmarking (SRao, 16:20:30)
    1. Installer scripts are ready. Alex to create github project - vsperf-k8s (SRao, 16:22:45)
    2. share access with the team. (SRao, 16:22:54)
    3. VSPERF without traffic-generation, phy2phy_tput. (SRao, 16:25:16)
    4. Alex will start with Multus - OVS and other plugins. (SRao, 16:25:46)

  3. Pod12 - Ixia TCLserver-Chassis Connectivity issue. (SRao, 16:28:18)
    1. It is still open; yet to be fixed. Intel team is working on it. (SRao, 16:28:32)
    2. While the test is running, collect the per-sec results frm the TGen. Results: Pks-sent, dropped, recvd, latency, etc. (SRao, 16:29:46)

  4. Clarifications. (SRao, 16:30:02)
    1. rx_bps_num: bps l2, rx_bps_den: bps L1 (SRao, 16:31:41)
    2. Goal of Drop-Pattern Analysis: Every iteration - we will collect the Drop-pattern. Associate this Drop-pattern to a type of loss (resource constraint or Transient) (SRao, 16:37:41)
    3. if we Loss-due-to-RC as A and Loss-due-to-Transient as B. By collecting lot of patterns, and learning from that pattern, can we categorize a new-pattern as A or B. (SRao, 16:38:56)
    4. Container and Kubernetes metrics: collectd or prometheus. (SRao, 16:43:43)
    5. 2 node [ master, and worker]. Kubernetes metrics collected Master, where container metrics is from the worker node. (SRao, 16:44:59)
    6. ACTION: Formal projects for both parth and Tushar in Wiki. (SRao, 16:45:58)
    7. ACTION: Sridhar to reschedule results container demo for Parth and Tushar. (SRao, 16:50:03)


Meeting ended at 16:52:08 UTC (full logs).

Action items

  1. Sridhar to send the complete log.
  2. Formal projects for both parth and Tushar in Wiki.
  3. Sridhar to reschedule results container demo for Parth and Tushar.


People present (lines said)

  1. SRao (32)
  2. collabot (3)
  3. acmacm (1)


Generated by MeetBot 0.1.4.