#opnfv-vswitchperf: vswitchperf

Meeting started by SRao at 16:00:44 UTC (full logs).

Meeting summary

  1. Development Update. (SRao, 16:00:59)
    1. : VSPERF Update patch is merged. Now, we have VSPERF with latest version of OVS, VPP, DPDK and Qemu. (SRao, 16:04:42)
    2. : Received reviews from Shailesh and AL for VSPERF containers. (SRao, 16:05:21)
    3. ACTION: Add Alex and Ancuta as reviewers. (SRao, 16:06:46)
    4. Created version-1 daemonset for the necessary setup (SRao, 16:09:22)

  2. CN Benchmarking (SRao, 16:09:32)
    1. Created version-1 daemonset for the necessary setup (SRao, 16:09:43)
    2. Working on the automation part. (SRao, 16:09:53)
    3. ACTION: Alex to update wiki with daemonset progression - single pod, dual-interface, 2-pods with each dual-interface, single pod with 3-interfaces. (SRao, 16:15:43)
    4. https://wiki.opnfv.org/display/vsperf/VSPERF-Container+Networking+Benchmarking+and+Testing (SRao, 16:16:16)
    5. vsperf-br0 (SRao, 16:17:47)
    6. ACTION: Sridhar to send alex the steps to run vsperf with "OVS" running without TGEN. (SRao, 16:18:56)

  3. Ixia Live-Results (SRao, 16:28:11)
    1. Ancuta shared the current statistics generated - Port level and the traffic level. (SRao, 16:33:20)
    2. Ancuta submit the changes (SRao, 16:35:03)
    3. ACTION: Sridhar to share with ancuta the path to write the files. (SRao, 16:35:19)

  4. Kubecon update (SRao, 16:37:43)
    1. Attended sessions Kubernetes Networking. (SRao, 16:37:55)
    2. Multiple interfaces is still an open problem - there are not of issues yet to be addressed. (SRao, 16:38:24)
    3. Attempts for multiple interfaces: celium and Calico. Get it working with celium is very difficult, even the authors are not sure about the approach. (SRao, 16:39:14)
    4. Calico: Its not clear if single instance of calico is sufficient. (SRao, 16:39:41)
    5. Most the networking solutions used in production are for single interfaces, and very few with dual-interface. (SRao, 16:40:26)
    6. No Demo on two data + 1 Mgmt interfaces. (SRao, 16:40:45)
    7. Most of the demos are targeting enterprises and very few for telcos. (SRao, 16:41:16)
    8. ACTION: Create/Update this information in Wiki. (SRao, 16:41:48)

  5. Container Metrics (SRao, 16:42:40)
    1. Parth is working on Prometheus based solution (SRao, 16:43:35)
    2. We need to collect all the related metrics. (SRao, 16:43:44)
    3. Yes. It is necessary (else there will be no receiver). (SRao, 16:44:06)
    4. But, you can write to files while you are testing. (SRao, 16:44:28)
    5. Update Results container with (a) Prometheus (b) Grafana dashboard for container metrics. (SRao, 16:45:25)
    6. (c) Connect Grafana with prometheus data. (SRao, 16:45:46)


Meeting ended at 16:47:02 UTC (full logs).

Action items

  1. Add Alex and Ancuta as reviewers.
  2. Alex to update wiki with daemonset progression - single pod, dual-interface, 2-pods with each dual-interface, single pod with 3-interfaces.
  3. Sridhar to send alex the steps to run vsperf with "OVS" running without TGEN.
  4. Sridhar to share with ancuta the path to write the files.
  5. Create/Update this information in Wiki.


People present (lines said)

  1. SRao (34)
  2. collabot` (3)


Generated by MeetBot 0.1.4.