#opnfv-vswitchperf: Vswitchperf

Meeting started by SRao at 16:02:35 UTC (full logs).

Meeting summary

    1. Development Update. (SRao, 16:02:44)

  1. Development Update (SRao, 16:04:05)
    1. Multidimensional TestVNF: Patch to build TestVNF with 10 Tools is submitted by Shubham. (SRao, 16:05:18)
    2. 10 Tools: Collectd, stressng, fio, unixbench, openssl, ndpi, trex, dppd-prox, dpdk, ramspeed. (SRao, 16:06:01)
    3. This patch will only build VNF with these tools. Whereas Config+Control will be done separately. (SRao, 16:07:01)
    4. For each of these tool, scripts to config and control will be added the TestVNF. Only then patch will be closed. (SRao, 16:08:25)
    5. Upgrade to Newer Versions of Kernel might be a challenge with DPDK. DPDK also has to be changed, and it needs Change in VSPERF Code. (SRao, 16:09:56)
    6. Before Upgrading to newer OS versions, we will have to ensure DPDK build with Newer Kernel Versions, in VSPERF. (SRao, 16:10:24)
    7. Enlist Target OS Version - The corresponding Kernel used - and matching DPDK Version. Then make changes in VSPERF code to build successfully. (SRao, 16:14:37)
    8. Going ahead with Newer Kernel also needs update of l2fwd application. https://github.com/opnfv/vswitchperf/tree/master/src/l2fwd (SRao, 16:15:42)
    9. ACTION: Connect with Emma Finn on this: L2Fwd and new Kernel Version Issue. (SRao, 16:16:46)
    10. acmacm tried Fedora 32 in general - was not nice as a vm on Vbox (acmacm, 16:16:47)
    11. We will go with DPDK 19.11.5 (LTS), Fedora 30. (SRao, 16:22:22)
    12. Q-to-answer: Which is the Most recent version of T-rex that we can use with VSPERF APIs? (SRao, 16:28:14)
    13. Works till 2.48. (SRao, 16:28:29)
    14. https://github.com/trexminer/T-Rex/releases (acmacm, 16:30:07)
    15. ACTION: Test with newer version of T-Rex on Pod12 (SRao, 16:31:56)

  2. CNB (SRao, 16:35:49)
    1. Cross-Numa Tests were completed. (SRao, 16:36:08)
    2. Plots are uploaded to Dropbox. (SRao, 16:42:11)


Meeting ended at 16:53:35 UTC (full logs).

Action items

  1. Connect with Emma Finn on this: L2Fwd and new Kernel Version Issue.
  2. Test with newer version of T-Rex on Pod12


People present (lines said)

  1. SRao (20)
  2. collab-meetbot (3)
  3. acmacm (2)


Generated by MeetBot 0.1.4.