#opnfv-vswitchperf: vswitchperf

Meeting started by SRao at 16:03:13 UTC (full logs).

Meeting summary

  1. Name-Change. (SRao, 16:03:29)
    1. ViNePerf name is approved. We will start using the name from next meeting. (SRao, 16:03:51)
    2. The IT-Ticket is opened to change the following: repo-name, jira-tag, mailing-list reference. (SRao, 16:04:29)

  2. Wiki-Update. (SRao, 16:04:53)
    1. In Wiki (https://wiki.anuket.io/) project is already renamed to VinPerf (Thanks to LFN team). (SRao, 16:05:26)
    2. Categories: Development, Experimental-Studies, Internships, Readouts and Articles, Releases, Summits & COnf, Test Mehtodologies. (SRao, 16:06:25)
    3. New category will be added - only if required. (SRao, 16:06:50)
    4. ACTION: Sridhar to change vsperf -> vineperf in wiki-pages. (SRao, 16:07:09)

  3. K8S CNB. (SRao, 16:07:56)
    1. Started the reruns today - VPP and RFC2544. (SRao, 16:09:29)
    2. VPP rx-miss Reason: rx-miss happens typically when vpp is not able to service rx queue (either because it is too busy or because kernel is not giving him opportunity to do the job) (SRao, 16:09:46)
    3. Increase the CPUs for VPP. (SRao, 16:10:15)
    4. Check if Increasing cpus to the VPP the rx-miss will decrease or not. (SRao, 16:11:18)
    5. Tried with VPP-Vhostuser with Userspace CNI. Unfortunately, for now, we cannot do this. (SRao, 16:13:10)
    6. Currently only combination allowed with VPP is memif (https://github.com/intel/userspace-cni-network-plugin/blob/master/cnivpp/cnivpp.go). (SRao, 16:14:18)
    7. OVS_DPDK with memif is a WIP for userspace CNI. (SRao, 16:15:43)
    8. Kubevirt: One of the options to run VMs in Kubernetes cluster. (SRao, 16:17:32)
    9. Open Question: How the performance is affected when the VM is encapsulated inside a container. (SRao, 16:18:08)
    10. This could a interesting problem to work on. (SRao, 16:19:18)
    11. Resource Requirement: Additional Disks on 2 servers. (SRao, 16:21:15)
    12. Pod Has 2 disks in each server, we may be able to use it. (SRao, 16:30:36)
    13. Trevor: Understand the datapath -- every element involved - in Kubevirt case. Once we know it, one can have an Idea about the performance bottlenecks. (SRao, 16:35:18)
    14. NSB of Yardstick may not be revived. We can consider reusing some components (libraries). (SRao, 16:53:27)
    15. (a) Look for extended-stats for multipod (b) Rerun -- while the test is run, we can collect more stats from switch/tgen. (SRao, 17:01:12)


Meeting ended at 17:02:44 UTC (full logs).

Action items

  1. Sridhar to change vsperf -> vineperf in wiki-pages.


People present (lines said)

  1. SRao (26)
  2. collab-meetbot` (3)


Generated by MeetBot 0.1.4.