#opnfv-yardstick: Yardstick-Functest joint meeting

Meeting started by anac1 at 07:00:01 UTC (full logs).

Meeting summary

    1. Ana Cunha (anac1, 07:00:29)
    2. QiLiang (QiLiang, 07:00:50)
    3. Morgan Richomme (morgan_orange, 07:01:06)
    4. Patrick (Patrick_, 07:02:25)

  1. Minutes from joint meeting yardstick-functest (anac1, 07:03:56)
    1. Morgan presents background (anac1, 07:04:39)
    2. Morgan demos the testing dashboard (anac1, 07:05:20)
    3. results from tests are currently not post-processed (anac1, 07:06:30)
    4. current functest results are shown (anac1, 07:08:16)
    5. intention is to use mongoDB as centralized collection for the testing from the test projects (anac1, 07:09:04)
    6. possible to push results to dB (anac1, 07:09:39)
    7. demo - functest last run from last night (anac1, 07:11:05)
    8. Jose Lausuch (jose_lausuch, 07:11:17)
    9. vping test - measures fail yes/no (anac1, 07:11:38)
    10. push results to dB after test execution (anac1, 07:12:28)
    11. mongodB trial in OrangeCloud (anac1, 07:13:51)
    12. create a test project in the dB (anac1, 07:15:42)
    13. declare test cases under the project (anac1, 07:16:03)
    14. results are stored following this structure - per pod (anac1, 07:17:40)
    15. payload is the results from the test run (anac1, 07:18:47)
    16. morgan shows the script he developed for the dashboard (anac1, 07:25:11)
    17. the script includes information on what to plot in the dashboard (anac1, 07:26:12)
    18. and the type of graph (e.g. bar, etc) (anac1, 07:26:33)
    19. need to consolidate the api (anac1, 07:28:35)
    20. need to develop unittest for the api (anac1, 07:28:50)
    21. need to move to target dB and test it (anac1, 07:29:06)
    22. proof of concept next week (anac1, 07:29:54)
    23. how long will th data be stores in dB ? (anac1, 07:32:04)
    24. no strategy yet, aim to store the entire release (anac1, 07:32:31)
    25. api version handling ? (anac1, 07:34:11)
    26. how is the structure of the dB handled ? releng is responsible fo the dB (anac1, 07:35:57)
    27. dB schema is stored in repo (anac1, 07:36:23)
    28. is releng also responsible for dB replication ? yes (anac1, 07:36:47)
    29. mechanism for backup the data should be developed by releng (anac1, 07:37:22)
    30. data model to be added in releng repo (anac1, 07:37:55)
    31. linux foundation is responsible for the dashboard, the data is responsibility of the project (anac1, 07:40:54)
    32. ACTION: anac to include qiliang in the proof of concept (anac1, 07:41:41)
    33. dashboard will be static, view after the test is executed (anac1, 07:44:30)


Meeting ended at 07:53:03 UTC (full logs).

Action items

  1. anac to include qiliang in the proof of concept


Action items, by person

  1. QiLiang
    1. anac to include qiliang in the proof of concept


People present (lines said)

  1. anac1 (49)
  2. collabot (6)
  3. QiLiang (4)
  4. morgan_orange (2)
  5. jose_lausuch (1)
  6. Patrick_ (1)


Generated by MeetBot 0.1.4.