#fdio-meeting: FD.io CSIT Project Meeting

Meeting started by mackonstan at 14:05:22 UTC (full logs).

Meeting summary

    1. Tibor Frank (tifrank, 14:05:41)
    2. Vratko Polak. (vrpolak, 14:06:55)
    3. Maciek Konstantynowicz (mackonstan, 14:07:52)

  1. Agenda bashing. (mackonstan, 14:08:04)
  2. VPP updates (mackonstan, 14:08:11)
    1. Andrew - rc1 in couple of weeks, will send email reminder (mackonstan, 14:08:37)

  3. TSC updates (mackonstan, 14:08:46)
    1. See Dave's noted actions (mackonstan, 14:10:09)
    2. https://ircbot.wl.linuxfoundation.org/meetings/fdio-meeting/2023/fd_io_tsc/fdio-meeting-fd_io_tsc.2023-08-31-15.00.html (mackonstan, 14:10:12)
    3. See minutes (mackonstan, 14:10:21)
    4. https://ircbot.wl.linuxfoundation.org/meetings/fdio-meeting/2023/fd_io_tsc/fdio-meeting-fd_io_tsc.2023-08-31-15.00.txt (mackonstan, 14:11:11)
    5. Heads-up: committer-at-large TSC membership - Nominations for comitter-at-large seats to be opened 2nd week of september (mackonstan, 14:12:00)
    6. ACTION: Dave to contact Arm folks about lack of funds for vpp-device servers (mackonstan, 14:12:43)
    7. https://lists.fd.io/g/tsc/message/1769 <-- LFN Governing Board Election: Call for Nominations (vrpolak, 14:13:20)

  4. E810 flow "offload" tests (mackonstan, 14:14:13)
    1. Kai: staying in backlog (mackonstan, 14:14:21)

  5. VPP and CSIT (not so hot) items (mackonstan, 14:14:44)
    1. re HW accelerator - SPR QAT2.0 (mackonstan, 14:15:56)
    2. Kai - still working on setting up a mirror CSIT environment in Shannon, as Yulong environment is no longer available, and following recommendations and instructions from Peter. (mackonstan, 14:16:43)
    3. Kai - currently having some issues with container bringup and NICs, Ranjan in on PTO this week, back on this as of tomorrow. (mackonstan, 14:17:22)
    4. re HW accelerator - SNR QAT2.0 (mackonstan, 14:17:43)
    5. Kai - there was a concern that processor may be replaced. Peter asked to run a set of commands, see email from Sebastian. (mackonstan, 14:21:53)
    6. HW accelerator - SPR DSA (mackonstan, 14:22:09)
    7. Kai: still waiting for BIOS release from SuperMicro - was expecting it on Intel calendar for wk35, now it's wk36. Kai is escalating it internally with John DG et to try and accelerate things. (mackonstan, 14:25:01)
    8. HW accelerator - E810 GTPU offload (mackonstan, 14:25:16)
    9. Peter: still an open item, to be investigated. (mackonstan, 14:26:33)

  6. CSIT-2306 RCAs (mackonstan, 14:27:04)
    1. Vratko: no updates. (mackonstan, 14:27:10)

  7. CSIT-2310 new release (mackonstan, 14:27:43)
    1. Kai: updated code for ipsec-mb for compatibility with dpdk 23.07 (mackonstan, 14:28:11)
    2. 39224: crypto-ipsecmb: bump intel-ipsec-mb version to 1.4 | https://gerrit.fd.io/r/c/vpp/+/39224 (mackonstan, 14:28:42)
    3. last comment from 23aug: "Indeed other changes are breaking backward compatibility. It is possible to preserve it but then further work on this patch is needed." (mackonstan, 14:30:11)
    4. Kai: team got a solution, working on it, should be ready for review soon, and in time for merging before rc1 on 20sep (mackonstan, 14:31:20)

  8. Physical Infrastructure (mackonstan, 14:31:39)
    1. Peter: install of 4 SPRs is in progress. 2 going into 1n-spr for vpp-device testing. (mackonstan, 14:32:06)

  9. Virtual Infrastructure, CI/CD (mackonstan, 14:33:10)
    1. Peter: 1n-skx vpp-device job still not voting, working with Dave to make it voting (fallout from Nomad CI being down last week). (mackonstan, 14:33:59)
    2. Vratko: Jenkins sandbox server is not working at the moment - https://jenkins.fd.io/sandbox/ (mackonstan, 14:35:51)
    3. https://jenkins.fd.io/sandbox/ (mackonstan, 14:35:54)

  10. VPP API tracking (mackonstan, 14:36:46)
    1. Vratko: out of 6 API change patches, only 1 got merged. (mackonstan, 14:37:08)
    2. Andrew: enough waiting time, will work with Dave to merge the rest. (mackonstan, 14:37:27)

  11. Trending and Test Failures (mackonstan, 14:37:39)
    1. Vratko: tracking some hoststack failures. (mackonstan, 14:39:02)
    2. nginx ldpreload tests broken by (mackonstan, 14:39:38)
    3. https://gerrit.fd.io/r/c/csit/+/39267/5/resources/libraries/robot/hoststack/hoststack.robot (mackonstan, 14:39:50)
    4. and then fixed by (mackonstan, 14:39:58)
    5. 39479: fix(hoststack): hardcode DUT1 for nginx | https://gerrit.fd.io/r/c/csit/+/39479 (mackonstan, 14:40:14)
    6. dpdk udp quick vppecho tests broken by (mackonstan, 14:40:51)
    7. https://jira.fd.io/browse/CSIT-1930 hoststack: investigate udpquicbase failure since 2023-08-10 (mackonstan, 14:41:20)
    8. 37858: session: async rx event notifications | https://gerrit.fd.io/r/c/vpp/+/37858 (mackonstan, 14:41:37)
    9. Vratko: re ldpreload on 3node testbeds - I suspect something infra related, but I do not understand the pattern. (mackonstan, 14:42:50)
    10. Vratko: 3n-alt job error spike but was CI errors related ... (Nomad CI issue last week) (mackonstan, 14:43:37)
    11. https://gerrit.fd.io/r/c/vpp/+/38304 (vrpolak, 14:46:46)
    12. 38304: interface dpdk avf: introducing setting RSS hash key feature | https://gerrit.fd.io/r/c/vpp/+/38304 (mackonstan, 14:47:10)
    13. Vratko: is there a chance to have this completed and merged before rc1? (mackonstan, 14:48:01)
    14. Kai: will follow up on this. (mackonstan, 14:48:15)
    15. Vratko: it's a root cause behind inconsistent perf results on e810. (mackonstan, 14:48:36)


Meeting ended at 14:52:01 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. mackonstan (57)
  2. collab-meetbot` (9)
  3. vrpolak (3)
  4. tifrank (1)
  5. dwallacelf (0)
  6. jlinkes (0)


Generated by MeetBot 0.1.4.