#onap-int: Integration weekly meeting 20/11/2019

Meeting started by morgan_orange at 14:05:30 UTC (full logs).

Meeting summary

  1. action point follow-up (morgan_orange, 14:06:23)
    1. http://ircbot.wl.linuxfoundation.org/meetings/onap-int/2019/onap-int.2019-11-13-14.00.html (morgan_orange, 14:06:32)
    2. AP1: morgan_orange brian create a list to submit to the committers (morgan_orange, 14:06:36)
    3. first list done and shared with existing committer (see admin section) (morgan_orange, 14:06:41)
    4. AP2: all review ElAlto retro page (morgan_orange, 14:06:46)
    5. https://wiki.onap.org/display/DW/El-Alto+Retrospective (morgan_orange, 14:06:51)
    6. Brian and myself did, do not hesitate to review especially all the aspects dealing with integration/tests (morgan_orange, 14:06:56)
    7. AP3 morgan_orange brian lukasz prepare a slide deck for PTL meeting to ask for healthcheck better quality with better coverage (morgan_orange, 14:07:33)
    8. topic mentioned in the el alto retrospective. A column has also be added in pari wise follow-up page https://wiki.onap.org/display/DW/0%3A+Integration+Weather+Board+for+Frankfurt+Release (healthcheck rating) (morgan_orange, 14:07:47)
    9. AP4: morgan_orange create a stable daily in windriver (morgan_orange, 14:08:58)
    10. windriver lab network issues since yesterday (gitlab-runner created but no more joinable) but additionnal work needed (see next section on lab) (morgan_orange, 14:09:07)
    11. AP5: all: complete etherpad to prepare Prague (morgan_orange, 14:09:16)
    12. https://etherpad.opnfv.org/p/onap_integration_prague (morgan_orange, 14:09:23)
    13. action point still open (morgan_orange, 14:09:30)
    14. AP6: morgan reinstall daily CI time series adapter to visualize test evolution = f(time) (morgan_orange, 14:09:41)
    15. work started, ingress point added on azure cloud hosting the conversion pod but still some issues (traffic not properly routed to the target pod) (morgan_orange, 14:09:50)

  2. admin (morgan_orange, 14:10:16)
    1. Lab status (morgan_orange, 14:10:22)
    2. windriver lab critical issues. OpenStack compute-03 is in error state. It hosted more than 30 VMs from different projects. These VMs have not been properly evacuated. Impossible to join the VM on 10.12.6.* (morgan_orange, 14:10:33)
    3. Jira raised Yesteday. Stephen was able to restart some of the components (access to Horizon) (morgan_orange, 14:12:29)
    4. but several if not all ONAP platform may be impacted by the hardware probelm on compute-03. (morgan_orange, 14:12:58)
    5. tickets have been raised on Intel Ops dealing with this DC (morgan_orange, 14:13:05)
    6. a move was also planned beginning of January (morgan_orange, 14:13:31)
    7. Ericsson lab no update (morgan_orange, 14:15:13)
    8. Orange: Daily chains (El Alto and Master) pretty stable since 1 week (morgan_orange, 14:16:05)
    9. E2E deployements are OK but longer (~ +5' per use case) due to modification in onap-tests python framework to manage multicloud. A patch has been submitted to configure this part (morgan_orange, 14:16:37)
    10. if issues continue on windriver, possible to grant access to the daily master if needed (but it is a daily...so it is reinstalled every day, the tests must be automated) (morgan_orange, 14:17:20)
    11. committer promotion (morgan_orange, 14:18:41)
    12. as mentioned in previous meeting, a new campaign for integration committer promotion started (morgan_orange, 14:18:51)
    13. first list is based on contributions to use cases: Bartek Grzybowski (vCPE) and E.Multanen (HPA vFW/vDNS), quorum of existing committers voted +1 for both (morgan_orange, 14:19:54)
    14. ACTION: morgan report committer vote to the TSC and update INFO.yaml (morgan_orange, 14:19:59)
    15. El Alto retrospective (morgan_orange, 14:20:45)
    16. https://wiki.onap.org/display/DW/El-Alto+Retrospective (morgan_orange, 14:23:34)
    17. RAN simulator repository (for 5G SON use case) created (morgan_orange, 14:24:16)
    18. https://git.onap.org/integration/simulators/ran/simulator/tree (morgan_orange, 14:24:24)
    19. CSIT mail notification finalized (morgan_orange, 14:25:02)
    20. CSIT cleanning still planned beginning of Decemeber (morgan_orange, 14:25:08)
    21. new script to build robot docker locally (morgan_orange, 14:25:15)

  3. El Alto Status (morgan_orange, 14:26:23)
    1. (src Brian) still pending issue in 1.7.6 SDNC DG’s. Final package left a bad version reference in the DG so the version loaded is not set as Active by default. (morgan_orange, 14:26:33)
    2. (src Brian) Need to change the version tag in the dg to ${project.version} or something instead of the hard coded 201904xx . Got missed in making the final container build and not seen till the last step of vCPE flow.c (morgan_orange, 14:27:00)
    3. SDNC-961 partly tested but does not fix everything (morgan_orange, 14:29:54)
    4. Frankfurt (morgan_orange, 14:30:08)
    5. oparent (morgan_orange, 14:30:43)
    6. (src Brian) oparent 3.0.0 not release yet (check with projects / Amy) (morgan_orange, 14:30:51)
    7. 2 tests already tested the new version, looking for a new team for testing (morgan_orange, 14:32:09)
    8. first results with oparent30.0.-snapshot OK (morgan_orange, 14:32:20)
    9. Policy and NBI has used this snapshot version => Ok (morgan_orange, 14:32:34)
    10. CI chains (morgan_orange, 14:32:55)
    11. Daily Master pretty stable (E2E tests run and OK) (morgan_orange, 14:32:59)
    12. AAI pod issue stil opened, JIRA assignement changed to AAI PTL + priority from low to high (morgan_orange, 14:33:49)
    13. https://jira.onap.org/browse/AAI-2707?filter=-2 (morgan_orange, 14:33:57)
    14. ACTION: morgan_orange see last dmaap errors on daily Master and create a Jira if needed (morgan_orange, 14:34:51)
    15. tests (morgan_orange, 14:35:37)
    16. (src Brian) GRA-API for generic VNFs seems to be working (morgan_orange, 14:35:46)
    17. (src Brian) GRA-API for infrastructe vCPE is complete. (morgan_orange, 14:35:51)
    18. (src Brian) - Waiting for tunnel-xcon DG’s to be modified by SDNC team to get vGMUX data from GRA-API instead of VNF-API side (morgan_orange, 14:36:10)
    19. (src Brian) - SO is planning to modify their customer vCPE serfvice workflow to be building block based so that will be a regression work load for Frankfurt. A good change but de-stabilizing (morgan_orange, 14:36:33)
    20. still remaining work to be automated on vCPE => use its own lab (not impacted by windriver issue) (morgan_orange, 14:37:24)
    21. (src Brian) Trying to understand ONAP – O-RAN-SC A1 and O1 interface work in Frankfurt. (morgan_orange, 14:38:23)
    22. xtestingization of the test in progress: dockers are available (infra-health (k8s, helm), health (core, small, medium, health, healthdist, postinstall, sdc-sdnc-d), smoke-usecases-pythonsdk (basic_vm, freeradius_nbi, clearwater_vims), smoke-usecases-robot (pnf_registrate, ...) (morgan_orange, 14:42:25)
    23. WIP on pnf_registrate (morgan_orange, 14:42:40)
    24. smoke-usecases-robot full python3 (morgan_orange, 14:44:41)
    25. ACTION: morgan migrate healthcheck in python3... (morgan_orange, 14:45:09)
    26. Python3 migration (morgan_orange, 14:45:10)
    27. robot RWO/RWX: today we use RWX => not cloud ready (morgan_orange, 14:55:34)
    28. if we keep our archi, we could easily move RWX => RWO (morgan_orange, 14:55:51)
    29. discussions to build base image => could be done by integration (morgan_orange, 15:02:00)
    30. question how to convince team to use referenced images... (morgan_orange, 15:03:45)
    31. OSJI: testing scripts about to be submitted (morgan_orange, 15:04:31)
    32. ACTION: morgan_orange send info on integration-xtesting to Krystof to see how to integrate some security tests on Daily chains (morgan_orange, 15:10:19)


Meeting ended at 15:10:29 UTC (full logs).

Action items

  1. morgan report committer vote to the TSC and update INFO.yaml
  2. morgan_orange see last dmaap errors on daily Master and create a Jira if needed
  3. morgan migrate healthcheck in python3...
  4. morgan_orange send info on integration-xtesting to Krystof to see how to integrate some security tests on Daily chains


Action items, by person

  1. morgan_orange
    1. morgan_orange see last dmaap errors on daily Master and create a Jira if needed
    2. morgan_orange send info on integration-xtesting to Krystof to see how to integrate some security tests on Daily chains
  2. UNASSIGNED
    1. morgan report committer vote to the TSC and update INFO.yaml
    2. morgan migrate healthcheck in python3...


People present (lines said)

  1. morgan_orange (77)
  2. collabot (4)


Generated by MeetBot 0.1.4.