#onap-int: Integration weekly meeting 1/07/2020

Meeting started by morgan_orange at 16:38:47 UTC (full logs).

Meeting summary

  1. action point follow up (morgan_orange, 16:38:55)
    1. https://ircbot.wl.linuxfoundation.org/meetings/onap-int/2020/onap-int.2020-06-18-05.26.html (morgan_orange, 16:39:03)
    2. AP1: morgan_orange krzysztof integrate preonboarding use case in CI Master (morgan_orange, 16:39:14)
    3. not done yet but still in mind... (morgan_orange, 16:39:23)
    4. ACTION: morgan_orange krzysztof integrate preonboarding use case in CI Master (morgan_orange, 16:39:50)
    5. AP2 morgan_orange contact Marco & Brian to get their feedback on Windriver/Intel Integration resources (morgan_orange, 16:40:01)
    6. done mail exchange, green light for integration tenant refactoring (morgan_orange, 16:40:13)
    7. AP3 morgan_orange create new project Integration-Terraform (morgan_orange, 16:40:25)
    8. done (morgan_orange, 16:40:26)
    9. AP4 all complete the etherpad to list possible scenarios (morgan_orange, 16:40:35)
    10. see next section (morgan_orange, 16:40:39)
    11. AP5 trevor provide the Bell upstream suite (need to select the place and check legal issues first) (morgan_orange, 16:40:50)
    12. AP6 Pawel W confirm we can swich from http endpoint to nonsslendpoint use case (morgan_orange, 16:40:57)
    13. not done (morgan_orange, 16:40:59)
    14. ACTION: morgan_orange Pawel W confirm we can swich from http endpoint to nonsslendpoint use case (morgan_orange, 16:41:04)
    15. AP7 thierry/Andreas discuss onapsdk scenario structure and push first scenario in ONAP repo (morgan_orange, 16:41:11)
    16. done first protoype available see next section (morgan_orange, 16:41:24)
    17. AP8 morgan_orange contacts OOM to precise that it would be great to keep last 2 stable versions in CI (morgan_orange, 16:41:31)
    18. everybody agrees on the principle, we are lacking resources (people and hardware) for the moment, but it would fully make sense, maybe a question to raise to TSC/PTL (morgan_orange, 16:42:18)

  2. stable branches (morgan_orange, 16:43:44)
    1. frankfurt status stable over the last week (morgan_orange, 16:44:00)
    2. https://docs.google.com/spreadsheets/d/1i3hPEqWwqggURXArrpum6I7j1Doao8HKWt-WBIG9gMg/edit?usp=sharing (morgan_orange, 16:44:13)
    3. issues are known issues (due to parallelization for vnf_) and due to hieratic behavior at AAI level for pnf-registrate => but globally it is fine (morgan_orange, 16:45:09)
    4. use case: maintenance release will be needed for some use cases.. (morgan_orange, 16:45:27)
    5. few patches seen on CDS (morgan_orange, 16:45:41)
    6. ACTION: morgan_orange ask Yuriy to get notified when patches are all in (needed for closed loop stuff out of the box) to self release testsuite 1.6.4 (morgan_orange, 16:46:28)
    7. agreed by Yuriy at the end of the session (morgan_orange, 16:46:41)
    8. regarding the request for support on frankfurt => most of the questions dealing with frankfurt issues are related to the installation( maria-galera resinstallation) (morgan_orange, 16:47:03)
    9. OOm patch on upgrade has been reverted => reported to Guilin (need more testing...) (morgan_orange, 16:47:23)
    10. El Alto maintenance release (morgan_orange, 16:47:35)
    11. CI run until beginning of May (switch to daily Frankfurt) on orange DC (morgan_orange, 16:47:44)
    12. Results wer OK and fixes (end of branches mainly deal with certificate issues) => no need to launch a full regression campaign all the more as, as all the use case owners are no more involved in ONAP it would be impossible to deal with the use cases. (morgan_orange, 16:47:51)
    13. Release manager asked if regression campaign was needed (expected according to our status) (morgan_orange, 16:48:12)
    14. answer was now: CI was fine until beginning of May, the only changes since this date deals with cert fixes (morgan_orange, 16:48:34)
    15. moreover impossible to ge El Alto use case owner (some moved to other projects). As the tests were poorly automated, almost all should be done manually (morgan_orange, 16:49:16)
    16. so no resources (neither humane nor hardware) to setup such regression campaign (morgan_orange, 16:49:54)

  3. admin (morgan_orange, 16:49:58)
    1. Windriver/Intel cleaning operation about to start (morgan_orange, 16:50:12)
    2. https://wiki.onap.org/display/DW/Windriver+lab+Frankfurt+cleaning+campaign (morgan_orange, 16:50:18)
    3. info resaid during PTL meeting, cleaning shall start before the end of the week (morgan_orange, 16:50:35)
    4. resources for terraform based installation created (morgan_orange, 16:50:52)
    5. robot-utils: repository is available => we could set a robot linter (not done on testsuite due to lots of errors but could be applied here) (morgan_orange, 16:51:02)

  4. Guilin (morgan_orange, 16:51:33)
    1. New JIRA board available (morgan_orange, 16:51:40)
    2. https://jira.onap.org/secure/RapidBoard.jspa?rapidView=221&selectedIssue=INT-1268 (morgan_orange, 16:51:46)
    3. cleaning also probably needed here as some JIRA were transfered from El Alto and did not move (morgan_orange, 16:52:03)
    4. new robot pod archi (morgan_orange, 16:52:12)
    5. testsuite/oom helm chart to be moved back to OOM (proposal to have both in // during transition phase) (morgan_orange, 16:52:19)
    6. leveraging on new architecture proposed by Daniel Rose (3 pods: 1 robot, 1 DB, 1 web server) (morgan_orange, 16:52:26)
    7. shall follow OOM recommendations (cloud native, security,..) (morgan_orange, 16:52:31)
    8. run the tests from inside the cluster/outside )> consequences (morgan_orange, 16:52:37)
    9. lucian already started working on this topic, should take the lead as some work already done to extract robot tests for ingress (morgan_orange, 16:53:03)
    10. but so far only AAI tests seem OK (morgan_orange, 16:53:09)
    11. other tests are calling internal components directly preventing the tests to be run as an end user (target) (morgan_orange, 16:53:31)
    12. Kzrysztof K indicates that it could be OK for some projects but clearly not all (pnf-registrate is directly calling the SO DB) (morgan_orange, 16:54:11)
    13. Kzrysztof O would like to see mark/label to know which tests are runnable from outside (morgan_orange, 16:54:37)
    14. ACTION: morgan_orange intiate a wiki page to track the status of Robot rests (runnable from inside/outside) and get the reason cause when it is not runnable from outside (morgan_orange, 16:55:10)
    15. some tests calling DCAE through HTTP Internal VES collector pod will not work (certificates need) (morgan_orange, 16:56:16)
    16. some exceptions are understandable but the rule shall be end user approach first, to be discussed case by case (morgan_orange, 16:56:41)
    17. Guilin Requirements dealing with VNF automation submitted by Lei (China Mobile) (morgan_orange, 16:57:01)
    18. https://jira.onap.org/browse/REQ-335 (morgan_orange, 16:57:09)
    19. https://jira.onap.org/browse/REQ-336 (morgan_orange, 16:57:13)
    20. https://jira.onap.org/browse/REQ-337 (morgan_orange, 16:57:17)
    21. https://jira.onap.org/browse/REQ-338 (morgan_orange, 16:57:20)
    22. need for automatio is shared, syncho session with CCMC this morning (morgan_orange, 16:57:40)
    23. they plan to update the tools they are used too (VTP / oclip / ) (morgan_orange, 16:57:58)
    24. in Integration we do not use these tools (yet) - the use case vCPE Tosca we tried to integrated in frankfurt is using these tools, so it could be integrated in CI (morgan_orange, 16:58:31)
    25. I shared the CI view including xtesting and existing tests (morgan_orange, 16:58:50)
    26. I suggest also that we could maybe create an Integration slot for Asian contributor at a more convenient timer if needed (morgan_orange, 16:59:22)
    27. REQ-338 is a bit different, it deals with certification, which is out of scope of Integration mission (morgan_orange, 16:59:50)
    28. regarding REQ-335, 336 and 337, Integration support them all the more as work has been already initiated in El Alto in this area with the introduction of CI chains (morgan_orange, 17:00:27)
    29. it is also not a problem to have 2 tooling chains (xtesting/python-sdk or robot versus VTP/oclip) (morgan_orange, 17:01:03)
    30. Jira had been created for the integratin of VTP in frankfurt (morgan_orange, 17:01:17)
    31. next goal, integrate vCPE Tosca and see if help is needed on their tooling chain (morgan_orange, 17:01:39)
    32. pythonsdk (morgan_orange, 17:01:44)
    33. First release available on pypi (morgan_orange, 17:01:51)
    34. https://pypi.org/project/onapsdk/ (morgan_orange, 17:01:59)
    35. thank to Michal and Sylvain for the first version (morgan_orange, 17:02:11)
    36. discussion on the possible scenarios to be created in https://git.onap.org/testsuite/pythonsdk-tests/ (morgan_orange, 17:02:28)
    37. First PoC proposed for scenario by Thierry https://gitlab.com/Orange-OpenSource/lfn/onap/pythonsdk-tests (morgan_orange, 17:02:50)
    38. morgan_orange created an issue to review the scenario datamodel - avoid using the same approach than in onap-tests (mix between sdk / scenario, with too many hardcoded things) (morgan_orange, 17:03:42)
    39. pythonsdk has been developed by developers, onap-tests by integrators => good moment to improve the sceanrio part based on dev best practices (unit test, coverage, object moedlization,..) (morgan_orange, 17:04:22)
    40. ACTION: michal sync with thierry/Andreas/Morgan to converge to the best scenario moedlization (morgan_orange, 17:04:43)
    41. Thierry implemented a scenario object as suggested in the Issue, onboarding/instantiation OK (morgan_orange, 17:05:14)
    42. to be reviewed by people interested in pythonsdk before we move the scenario to ONAP repo (morgan_orange, 17:07:54)
    43. new use cases (morgan_orange, 17:07:55)
    44. first try on check certificates: dealing with nodport/internal/ingress => to be integrated in CI (morgan_orange, 17:08:04)
    45. https://gerrit.onap.org/r/c/integration/+/109207 (morgan_orange, 17:08:04)
    46. please committer review and merge => I will add it it CI (morgan_orange, 17:08:47)
    47. preonboarding, vcpe_tosca still in the loop (morgan_orange, 17:08:48)
    48. Upstream cds tests are coming (morgan_orange, 17:08:48)
    49. legacy tests could also be tested ..from the cluster, use the tag.. (morgan_orange, 17:08:48)
    50. ACTION: morgan_orange give a try to CDS test for next week (morgan_orange, 17:08:48)
    51. security test: (morgan_orange, 17:08:48)
    52. cleaning of the xfail lists on master? (morgan_orange, 17:08:48)
    53. ACTION: morgan_orange contact SECCOM to see if we can reset the xfail list now or if we should wait a milestone (morgan_orange, 17:08:50)
    54. http enpoint => update: switch to nonssl? (Paweł Wieczorek ) (morgan_orange, 17:08:51)
    55. ACTION: morgan_orange contact Pawel W to see if we are OK to switch (morgan_orange, 17:08:51)
    56. which threshold fro limits? (morgan_orange, 17:08:51)
    57. add the question for SECCOM (morgan_orange, 17:08:51)
    58. check version according to SECCOM recommentations => ask SECCOm to move their list through a file in their repo to get a gerrit reference rather than a wiki page? (morgan_orange, 17:08:51)
    59. a usecase is ready, pawel should submit it next week (morgan_orange, 17:08:52)
    60. ACTION: morgan_orange integrate the test in CI (morgan_orange, 17:08:59)

  5. AoB (morgan_orange, 17:09:03)
    1. windriver ci from gitlab.com: I was able to install the full Openstack resources + launch the kubespray installation but still facing some issues...to be continued (morgan_orange, 17:09:42)
    2. question from Ali on the v2F2 video (morgan_orange, 17:09:54)
    3. https://wiki.lfnetworking.org/display/LN/2020+June+Virtual+Recordings (morgan_orange, 17:11:33)
    4. python SDK video is here (morgan_orange, 17:11:55)
    5. https://wiki.lfnetworking.org/download/attachments/40370243/Python%20ONAP%20SDK.mp4?api=v2 (morgan_orange, 17:11:57)
    6. and documentation can be found in (morgan_orange, 17:13:55)
    7. https://python-onapsdk.readthedocs.io/en/latest/description.html# (morgan_orange, 17:13:55)


Meeting ended at 17:13:55 UTC (full logs).

Action items

  1. morgan_orange krzysztof integrate preonboarding use case in CI Master
  2. morgan_orange Pawel W confirm we can swich from http endpoint to nonsslendpoint use case
  3. morgan_orange ask Yuriy to get notified when patches are all in (needed for closed loop stuff out of the box) to self release testsuite 1.6.4
  4. morgan_orange intiate a wiki page to track the status of Robot rests (runnable from inside/outside) and get the reason cause when it is not runnable from outside
  5. michal sync with thierry/Andreas/Morgan to converge to the best scenario moedlization
  6. morgan_orange give a try to CDS test for next week
  7. morgan_orange contact SECCOM to see if we can reset the xfail list now or if we should wait a milestone
  8. morgan_orange contact Pawel W to see if we are OK to switch
  9. morgan_orange integrate the test in CI


Action items, by person

  1. morgan_orange
    1. morgan_orange krzysztof integrate preonboarding use case in CI Master
    2. morgan_orange Pawel W confirm we can swich from http endpoint to nonsslendpoint use case
    3. morgan_orange ask Yuriy to get notified when patches are all in (needed for closed loop stuff out of the box) to self release testsuite 1.6.4
    4. morgan_orange intiate a wiki page to track the status of Robot rests (runnable from inside/outside) and get the reason cause when it is not runnable from outside
    5. morgan_orange give a try to CDS test for next week
    6. morgan_orange contact SECCOM to see if we can reset the xfail list now or if we should wait a milestone
    7. morgan_orange contact Pawel W to see if we are OK to switch
    8. morgan_orange integrate the test in CI


People present (lines said)

  1. morgan_orange (113)
  2. collab-meetbot (3)


Generated by MeetBot 0.1.4.