#opnfv-testperf: testing working group weekly meeting January 19th

Meeting started by morgan_orange at 15:01:23 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 15:01:27)
    1. Mark Beierl (mbeierl, 15:01:36)
    2. Morgan Richomme (morgan_orange, 15:01:41)
    3. kubi (kubi001, 15:01:43)
    4. Trevor Cooper (trevor_intel, 15:02:00)
    5. Yujun Zhang (yujunz, 15:02:04)
    6. Jose Lausuch (jose_lausuch, 15:02:10)

  2. action point follow up (morgan_orange, 15:03:28)
    1. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2017/opnfv-testperf.2017-01-11-08.07.html (morgan_orange, 15:03:31)
    2. APi kubi001 make synthesis of the proposal for week 4 (morgan_orange, 15:05:18)
    3. ACTION: point APi kubi001 make synthesis of the proposal moved to week 6 (morgan_orange, 15:05:37)
    4. hongbo (hongbo55, 15:07:08)
    5. done (morgan_orange, 15:07:17)
    6. https://wiki.opnfv.org/display/meetings/TestPerf (mbeierl, 15:07:20)
    7. morgan_orange sync with infra group to see if it is possible (morgan_orange, 15:07:24)
    8. not done yet (morgan_orange, 15:07:28)
    9. ACTION: morgan_orange sync with infra group to see if it is possible (nned lab for long duration tests) (morgan_orange, 15:07:38)
    10. morgan_orange organize meeting on Alassane work (either on week 3 or 6) (morgan_orange, 15:07:46)
    11. done (morgan_orange, 15:07:47)
    12. ad-hoc meeting organized this week (morgan_orange, 15:08:02)
    13. Alassane created a wiki page (morgan_orange, 15:08:09)
    14. https://wiki.opnfv.org/display/testing/R+post-processing+of+the+Yardstick+results (morgan_orange, 15:08:17)
    15. presentation could be re do for US if needed (morgan_orange, 15:08:27)
    16. open quesiton on the project where we could include this post processing module (morgan_orange, 15:08:40)

  3. unit tests (morgan_orange, 15:08:45)
    1. mbeierl sharing presentation on unit tests (video of Berlin summit available on youtube) (morgan_orange, 15:10:07)
    2. slide 9 - tests as documentation (mbeierl, 15:15:48)
    3. test as documentation => show how to use an API (morgan_orange, 15:17:34)
    4. no need to unit test too simple things (getter/setter) (morgan_orange, 15:17:53)
    5. Tests shall not launch a missile (trevor_intel, 15:18:34)
    6. unit test you can mock your mock and you will get mock results! (morgan_orange, 15:19:51)
    7. https://build.opnfv.org/ci/view/storperf (mbeierl, 15:24:06)
    8. https://build.opnfv.org/ci/view/storperf/job/storperf-verify-master/123/cobertura/ (jose_lausuch, 15:24:39)

  4. Communication action on OPNFV testing (Jill Lovato) (trevor_intel, 15:29:15)
    1. code coverage reports on the % of code from inside the git repo for the project (mbeierl, 15:29:41)
    2. https://newsroom.cisco.com/press-release-content?articleId=1812628 (trevor_intel, 15:31:09)
    3. OPNFV would like to communicate on testing activities (morgan_orange, 15:32:45)
    4. document in progress (morgan_orange, 15:32:49)
    5. https://docs.google.com/document/d/1O1BKT7OVXwA8YlIXPcad9_Gk0--0-h-9Zvpio-0H8Ok/edit?usp=sharing (morgan_orange, 15:34:26)
    6. target end of month (morgan_orange, 15:35:37)
    7. ACTION: testing community invited to review the documentation (morgan_orange, 15:36:20)
    8. ACTION: morgan_orange set slot during next weekly meeting to sync testing group view (morgan_orange, 15:37:57)

  5. New diagram proposal (morgan_orange, 15:38:27)
    1. https://wiki.opnfv.org/display/testing/TestPerf?preview=/8688867/8688868/EcoSystem%20Copy.png (morgan_orange, 15:38:44)
    2. ACTION: trevor_intel send a mail to the community to share the figure for review (morgan_orange, 15:45:48)
    3. feature tests not reflected here (morgan_orange, 15:45:57)
    4. use benchmarking instead QPI (morgan_orange, 15:46:10)
    5. functest and yardstick can be used to help feature project to run their own tests (morgan_orange, 15:49:11)

  6. dovetail update (morgan_orange, 15:49:16)
    1. https://wiki.opnfv.org/display/qtip/Vision (yujunz-zte, 15:57:34)
    2. https://ask.opnfv.org/question/1273/swagger-access/ <- people are asking for testresults db username and password. Is this publicly available or no? (mbeierl, 15:59:52)
    3. http://testresults.opnfv.org/test/api/v1/projects/dovetail/cases (morgan_orange, 16:02:45)
    4. http://testresults.opnfv.org/test/api/v1/projects/functest/cases (morgan_orange, 16:02:58)


Meeting ended at 16:05:52 UTC (full logs).

Action items

  1. point APi kubi001 make synthesis of the proposal moved to week 6
  2. morgan_orange sync with infra group to see if it is possible (nned lab for long duration tests)
  3. testing community invited to review the documentation
  4. morgan_orange set slot during next weekly meeting to sync testing group view
  5. trevor_intel send a mail to the community to share the figure for review


Action items, by person

  1. kubi001
    1. point APi kubi001 make synthesis of the proposal moved to week 6
  2. morgan_orange
    1. morgan_orange sync with infra group to see if it is possible (nned lab for long duration tests)
    2. morgan_orange set slot during next weekly meeting to sync testing group view
  3. trevor_intel
    1. trevor_intel send a mail to the community to share the figure for review


People present (lines said)

  1. morgan_orange (53)
  2. trevor_intel (11)
  3. mbeierl (11)
  4. yujunz-zte (8)
  5. ChrisPriceAB (6)
  6. collabot (4)
  7. kubi001 (3)
  8. jose_lausuch (3)
  9. yujunz (2)
  10. hongbo55 (1)
  11. pjlynch (1)
  12. bryan_att (1)
  13. gabriel_yuyang (1)


Generated by MeetBot 0.1.4.