#opnfv-testperf: Testing working group weekly meeting 6th of July
Meeting started by morgan_orange at 15:00:43 UTC
(full logs).
Meeting summary
- call roll (morgan_orange, 15:00:54)
  - Morgan richomme (morgan_orange,
    15:01:01)
- https://global.gotomeeting.com/join/819733085
    (mbeierl,
    15:01:13)
- Mark Beierl (mbeierl,
    15:01:22)
- Yujun Zhang (yujunz-zte,
    15:01:26)
- Jack (JackChan,
    15:01:45)
 
 
- action point follow up (morgan_orange, 15:03:23)
  - http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2017/opnfv-testperf.2017-06-29-15.00.html
    (morgan_orange,
    15:03:43)
- AP1: organ_orange change swagger login/password
    (publically available in the book...) (morgan_orange,
    15:04:10)
- ACTION: morgan_orange
    update status to amar (morgan_orange,
    15:06:26)
- AP2 add better mechanism to track access to the
    API (morgan_orange,
    15:06:51)
- work in progress through web protal /API
    (morgan_orange,
    15:07:01)
- morgan_orange send a mail for a status
    (morgan_orange,
    15:07:09)
- ACTION: morgan_orange
    send a mail for a status on landing page (morgan_orange,
    15:07:24)
- AP4 morgan_orange initiate a wiki page on
    tooling (morgan_orange,
    15:07:37)
- started see next slot (morgan_orange,
    15:07:42)
- AP5 jose_lausuch start a email thread to see if
    we should reset the black list for each new versions / up to
    scenario owners / exceptios shall be validated by TSC? (morgan_orange,
    15:07:53)
- discussions related to Danube 3.0 - main
    concern is on the failed temepst cases (morgan_orange,
    15:08:46)
- a reste for Euphrates has been done to clean
    the black list (all installers/all scenarios) (morgan_orange,
    15:09:07)
 
 
- Short status On EnergyAaS activity (morgan_orange, 15:10:17)
  - presentation of the work done by Benoit around
    Energy consumption (morgan_orange,
    15:11:34)
- google knows which application is consuming too
    much power on smartphone, the idea was to start doing something
    similar on NFVI (which VNF / application / ) consumes what
    (morgan_orange,
    15:12:29)
- possible to leverage OPNFV Pharos federation,
    with deterministic runs thanks to CI pipelines (morgan_orange,
    15:13:02)
- https://wiki.opnfv.org/display/testing/Power+consumption+monitoring
    (morgan_orange,
    15:13:29)
- presentaiton during the summit on benoit's
    work (morgan_orange,
    15:14:10)
- https://www.youtube.com/watch?v=jVc9Z5OuIYY&list=PLiM029E-zvrtlTmH0h0mHt_-g8B-6609P&t=16s&index=25
    (morgan_orange,
    15:14:13)
- first results  (first PODs equiped)
    (morgan_orange,
    15:17:28)
- http://opnfv.fr:3000 (morgan_orange,
    15:17:33)
- on E//, LF POD2 it is possible to see the whole
    CI cycles (morgan_orange,
    15:18:50)
- on Orange-POD3 Benoit added the possibility to
    get more details through the SDK for specific use (morgan_orange,
    15:19:26)
- question from Mark where shall we integrate it
    for stress tests (Bottlenecks?) (morgan_orange,
    15:26:57)
- for the moment collector code is not yet in
    OPNFV ... need to figure out where to put it (morgan_orange,
    15:27:32)
- ACTION: benoit send a
    mail to the community to evaluate the need for such activity around
    Energy (morgan_orange,
    15:32:33)
- New project or could it be hosted in Pharos see
    with jack Morgan? (morgan_orange,
    15:32:38)
- trevor_intel mentioned that Energy monitoring
    could be interesting for security topics (morgan_orange,
    15:34:39)
- discussions on collector (IPMI, Redfish, HUI
    scrapping) (morgan_orange,
    15:37:17)
 
 
- Bitergia sync point (morgan_orange, 15:39:54)
  - synchro next week (morgan_orange,
    15:40:12)
- Jesus "We have some data collected in an
    enriched in Kibana" (morgan_orange,
    15:41:53)
- https://opnfv.biterg.io:443/goto/93ebe8aca496facba752ced47379e1b4
    (morgan_orange,
    15:42:03)
- The index has only some data because the data
    retrieval from the API failed when retrieving a longer time frame.
    Álvaro already reported the problem. (morgan_orange,
    15:42:11)
- There is a very preliminar version of a panel
    for visualizing the data. Even when it still needs some work, and it
    is showing a small dataset (because of the above problem) you can
    start commenting on it, if you want (at least to know if you feel
    we're on the right direction or not). (morgan_orange,
    15:42:20)
- https://opnfv.biterg.io:443/goto/dd9aa660f1fa5d8dd63f7f455609aa80
    (morgan_orange,
    15:42:31)
 
 
- Tooling catalog (morgan_orange, 15:43:41)
  - work initiated (morgan_orange,
    15:43:51)
- https://wiki.opnfv.org/display/testing/Testing+tooling+catalog
    (morgan_orange,
    15:44:06)
- remark from yujunz: list only the external
    tools or indicate python requirements? (morgan_orange,
    15:44:29)
- ACTION: everybody
    complete the table..we will discuss next week (morgan_orange,
    15:44:43)
 
 
- Dockerfile discussion (morgan_orange, 15:44:58)
  - more than one dockerfile (for compose) per
    project, and can we use merge jobs to trigger docker push instead of
    timer? (morgan_orange,
    15:45:08)
- yujunz-zte suggests if we want to include
    python requirements, we can do it automatically by writing a script
    to pull all requirement.txt from different projects (morgan_orange,
    15:47:25)
- https://docs.docker.com/docker-hub/builds/
    (yujunz-zte,
    15:48:49)
- for the moment the logic to build docker file
    is in releng, docker file is in the project repos (morgan_orange,
    15:50:47)
- https://git.opnfv.org/releng/tree/jjb/releng/opnfv-docker-arm.yml
    https://git.opnfv.org/releng/tree/jjb/releng/opnfv-docker.yml (jose_lausuch,
    15:52:46)
- https://git.opnfv.org/releng/tree/jjb/releng/opnfv-docker.yml#n130
    (jose_lausuch,
    15:55:26)
- ACTION: jose_lausuch
    mbeierl review changes needed to support multiple docker in
    releng (morgan_orange,
    15:57:56)
- ACTION: mbeierl
    jose_lausuch evaluate moving from cron to post merge mechanism for
    docker production (morgan_orange,
    15:58:13)
 
 
- AoB (morgan_orange, 15:58:24)
  - Can anyone think of a good way to deliver
    docker-compose.yaml files to end users? (mbeierl,
    15:58:49)
- next meeting APAC slot 12th of July
    (morgan_orange,
    15:58:57)
- https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2017-June/016857.html
    (yujunz-zte,
    16:01:41)
 
Meeting ended at 16:01:59 UTC
(full logs).
Action items
  - morgan_orange update status to amar
- morgan_orange send a mail for a status on landing page
- benoit send a mail to the community to evaluate the need for such activity around Energy
- everybody complete the table..we will discuss next week
- jose_lausuch mbeierl review changes needed to support multiple docker in releng
- mbeierl jose_lausuch evaluate moving from cron to post merge mechanism for docker production
Action items, by person
  -  jose_lausuch 
    - jose_lausuch mbeierl review changes needed to support multiple docker in releng
- mbeierl jose_lausuch evaluate moving from cron to post merge mechanism for docker production
 
-  mbeierl 
    - jose_lausuch mbeierl review changes needed to support multiple docker in releng
- mbeierl jose_lausuch evaluate moving from cron to post merge mechanism for docker production
 
-  morgan_orange 
    - morgan_orange update status to amar
- morgan_orange send a mail for a status on landing page
 
- UNASSIGNED
    - benoit send a mail to the community to evaluate the need for such activity around Energy
- everybody complete the table..we will discuss next week
 
People present (lines said)
  - morgan_orange (60)
- yujunz-zte (12)
- collabot` (6)
- rbbratta (4)
- mbeierl (4)
- jose_lausuch (2)
- JackChan (1)
- trevor_intel (0)
- gabriel_yuyang (0)
- kubi001 (0)
Generated by MeetBot 0.1.4.